My Passport Essentials SE - Not recognized by car- 2010 Cadillac SRX - Linux


#1

Hi,
I just bought a brand new 2010 Cadillac SRX with premium package, navigation, and rear seat entertainment. The Cadillac has a USB port and is supposed to recognize files of type .wma, .mp3, and divix movies. I tried it with my iPhone and with a small 1GB thumbdrive that I had from work, both worked.

So I went to Costco and bought a 1TB My Passport Essential SE so that I could put my entire music collection in my new car.

I have successfully accessed music files on a small thumb drive from another manufacturer in the car, however, when I connect my new My Passport Essential SE 1TB drive to the car it gives me an error “This Media cannot be used”. I’ve tried with the same songs saved to a small thumb drive and they work fine, so I know it’s not the content on the drive, but perhaps some other aspect of the drive.

When I originally purchased it last week it came formatted as NTFS. Since the Cadillac system is likely based on a linux platform I guessed that the problem was the formatting. I downloaded a tool (Guiformat.exe - the UI version of FAT32Format.exe) to reformat the drive as FAT32. I tried with 64k clusters and a quick format, which failed to solve the problem (the drive was formatted and I was able to copy and play songs on both my windows machine and my mac, but the car still did not recognize the drive).

I then tried to reformat it with a FULL FORMAT (not a quick format) and chose the next smaller cluster size 32k. This took 24 hours. The car is still unable to use the WD device (but my other 1G thumbdrive works fine). Is there some trick (some other driver, firmware, or formatting scheme) that I can use to make this drive recognizable by a linux computer?

Isn’t “Universal Serial Bus” supposed to be “Universal”  - no drivers needed?

Please help.

Thanks, Ken