My Passport Essentials 0730 750GB not working!

Somebody please help me I am losing my mind over this problem.

I have a My Passport Essentials. On devices and printers it says My passport 0730. I do not know exactly anything else besides this. It is a 750 GB external hard drive. I have two others and a terabyte and they work perfectly fine on my laptop. This one just does not want to cooperate. I plug it in and wait for it to be recognized. After a long time it shows up on My Computer but only as a Local Disk F: and does not show the data usage like the others. When I try to access the drive My Computer slows down and will not access the drive at all. The drive eventually disappears and pops up again after a minute or two. When I try to access the drive through the Devices and Printers page it slows down as well, disappears, or slows down to a crawl for a simple right click. 

I have tried to go to Computer Management and the Disk Management. I can see the drive in Disk Management as Disk 1 with 698.61 GB and it says it is Online. However it does not show up where my c: and d: drive does to say it is healthy. When I disconnect the drive with Disk Management open it momentarily says the drive is RAW data literally as it disconnects and a pop up says that the drive needs to be formatted before use. Formatting this way does not work.

I have tried WD Quick Formatter and it does recognize the disc for a moment and when it is formatting it pops up with a message about how it unexpectedly is closing and cannot perform the format. 

Also when the drive is connected My computer slows down and my Google Chrome will freeze and not respond unless I disconnect the drive.

The data is not an issue since I have much of it on the other drives but I need this drive to work. Is there anything I can do to fix it or can someone direct me to the problem? The drivers are up to date because that used to be the troubleshoot problem but now the computer is saying the device is working properly. The last thing I did with the drive is transfer a home video onto it. After connecting it to my Xbox the xbox froze and connected it to the computer. 

Please someone help me!!!


Connect the drive to a desktop computer, then download the DLG tool from the WD website, write zeroes to the drive and go to disk management to allocate the unit, this should work and make the unit operative.


I have tried this before on my laptop and just tried it on a desktop. Still freezes the application unless I unplug the drive. 

Are there any other suggestions? I would appreciate the help.

I am having the same issue with my 0730 1TB. Exactly the same, down to Chrome freezing. I left my drive connected after Chrome crashed, and like 20 minutes later it unfroze and mounted my partition. I am transfering my data from it, but it is reading soooo slow, took me 5 minutes to transfer 24 mb of pictures. Just curious, how much free space is on your drive? I only have 70 gb of mine free. As I filled the drive up, it has been getting slower and more buggy. I have been a long time fanboy of WD but in the last year I have had 2 internal and 2 external WD drives fail, and the last hd i own (WD 60 gb caviar IDE) is on it’s way out too. :\