My Passport Essential SE NOT Inisialized why?

has purchased before My Passport Essential SE  Of the type of WDBAC0010BBK , i did plug it with my labtop ,  He worked in a manner that is true
without problems , But after a period were electricity disconnect of my labtop , then  i restart my computer But the WD did not work… A number of ways that tried to unplug WD and Plug it with separated usb place … it
again without interest… When I went for the device manager it’s Related correctly but is not apparent in the my computer See in the picture below here the problem at management of disk  ?

please help me i need my files at that i stored in my WD ?  

Your partition data is probably corrupt. Maybe TestDisk will fix it. If it looks to complicated try this one


Thank you Joe_S for your help …!

But I did try your post for resolve my problem without any usefull , I downloded tow app from above links and i tried it for resolve this problem then my WD it’s alpparent  at  Computer Management at Disk management by name (disk1) discribtion of this disk is not unknown and  NOt inisialized ?? what’s the problem may be WD was damaged ??

No answer ?