My passport essential se failed

hi, I got a WD passport essential five month ago, and I use the drive lock to protect my drive. it works well for the five month.

yesterday, while I was watching a movie in my drive, I opened VmWare Virtual Machine and the virtual machine automatically removed my passport essential from my computer, I immediately disconnected it from the virtual machine, but my drive does no work any more. Windows 7 shows that it needs to install some driver for it, but failed for WD SES Driver and Disk drive. the virtual cd in my Computer is wrong as if it does not have any CD disk in it.

my passport essential.jpg my passport essential.jpgthe WD SmartWare no longer discover my drive, and when I open the Smartware, it takes some time for it to response. when the SmartWare responses, it asks me to unlock my drive. But I tried my password, it does not work. I’m very sure that the password I tried is the one before my drive went down. When I use WD QuickFormater to try to format it(but I did not), the SN shows there was S0123456789A, strange, isn’t it? How can I do now? I do not want to format my drive cause I have a lot of unbackuped data in it.

Itsounds like something got corrupt connecting and disconnecting from VM. If you want to reformat type password 5 or 6 times and it should brong up a box to clean drive.

Joe

Hi there, Apparently this is drive corruption, see if is possible for you to run ScanDiskand Defragment the drive, If is not possible we might need to reformat the drive, click here to see the instructions.