My Passport Essential SE Crashes System


I’m new here, joined up as I’m facing an incredibly annoying problem.

I was recently given a My Passport Essential SE 1TB drive and after following the installation guides I tried to make my first backup. It seems to crash my system without fail after around 10 minutes of backing up data. Initially I used the Smartware software, however I uninstalled this and tried without any software by copy and pasting data - I had the same issue. The only way to resolve is to turn off and reboot the laptop.

I am running a Toshiba Laptop, Windows Vista 32 bit, 2GHz Core 2 Duo, 3GB RAM.

Is there something I am missing that is causing my system to hang up everytime I try to copy data to the drive? I read the knowledge base page about Sonic DLA software causing a similar problem but I do not have this software on my machine.

I have thought about formatting the drive incase any of the problems are due to some sort of Smartware issue. I would like to try and preserve what is on the drive if possible but if this will fix the problem I will not hesitate. I have contacted WD support but as of yet have received no response.

Thanks for any help!


Please try to read most of the posts in this forum for last couple of weeks. I am sure you’ll find your answer. It will take only half an hour or so. :smiley:

Oh… I know that,  this is not the straight forward answer you were looking for. But I am tired of talking about typical file and partition table corruption issues on My Passport Essential SE 1TB drive again and again. And I don’t believe WD DLG utility could fix it.

Mabikay – SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

Sorry, I had looked through the forum, I didn’t feel as if any answered what I was after, maybe they were just now worded the same way as my question.

Can you point me to the specific issue I am looking for?

I’ll get reading again anyway!


Okay… I’ll get back to you soon.

Mabikay - SLK


Just wanted to add a bit more information. I have had no issues at all about the drive being recognised, the drive is assigned a drive letter and is accessible. The problem only occurs when transferring data, it causes a full computer crash. The drive continues to spin, constant on LED and my computer is totally hung up.

I am sorry as I kept you waiting!

1)      Check connecting your drive to another PC and copying some files to it. If this is successful, try copying back from your drive to another location. If that is also okay, try deleting same files from your Passport drive. If your drive able to perform all above steps, your drive “apparently” okay.

2)      Now, anyone of those steps was unsuccessful, either you have a corrupted disk or drive electronics.

3)      Issues with drive electronics cannot be de fixed and need to look for possible warranty replacement.

4)      If drive has a corrupted file system and if you have run WD DLG software or Windows Check disk utility, you drive may have a few or more bad sectors marked as unusable.

5)      You may be able to recover your disk drive by using a utility named HDD Regenerator 2011. First download the trial version from original developer site here. (You should not have Smartware installed in this test PC)

6)      First try “Under Windows” option and try to pre-scan your drive.  If that is unsuccessful, try making a boot disk and scan using bootable disk. If any one of these scanning was successful you can go ahead and run the “Repair Mode”. The trial version will fix only one bad sector. Now look in *bay for $0.00 solution. You’ll find HDD Regenerator.exe within a zip file. Now copy and replace the same file in Program Files\HDD Regenerator folder. Nothing else.

7)      If you like you can buy the full version from same site you download the trial.

8)      But if the PC freezes on any mode of HDD Regeneration process (even on different PC), I am confident that you have a hardware issue.

Good Luck

Mabikay – SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

BTW, what type of cable you use on My Passport? If it is black and very tight fitting on drive side, you’re okay. if the connection is loose, then you’ll have obtain free replacement cable from WD. That should solve many issues.

Mabikay - SLK

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.

Thanks Mabikay, I will try those steps and see how things go.

Support have replied to me at last and just gave me steps to assess the drive through the Data Lifeguard Diagnostics. Quick test came up fine, running an extended test now and then will try your steps. I will take the drive into work tomorrow and see where I get to.

It is so frustrating. I had the product gifted to me as it had been bought as a very good looking drive but to have so many problems out the box is just shocking. The number of posts in this forum speaks for itself.