My Passport Essential SE and ps3

I tried to hook up my ps3 with my  passport essential se but the ps3 doesnt recognize it…any solutions?

Did you reformat it to FAT32? That’s what PS3 needs.



I also have the same problem.

And the disc is already reformatted to FAT32.

When I plugged in to the PS3, you can feel it running, but the activityled doesn’t light up. And the PS3 doesn’t detect the hdd.

Who can help ?


Sounds like it might be a power issue. They make a power booster cable that might help. It uses 2 USB ports.


Maybe another VCD problem ?

VCD is the 1st (and permanent) partition and PS3 is not able to “read” the 2nd partition ?

I think they need to be formatted FAT32 LOGICAL.


I have the same problem, WD My Passport Essential SE, USB3+USB2 compatible. 1TB.

I deleted the partion and formatted a logical FAT32 using Easus Partition Manager

Drive works fine on Windows PC, light comes on when plugged in, flashes during access.

Plug it into PS3 and I can feel the disk is powered up, cannot access it and light does not come on.

Plug it directly into a power socket and again can feel it’s on but no light - So I don’t think the issue is that the PS3 isn’t giving enough power.

I don’t know exactly what VCD is but I can’t see any other partitions on the disk, and i did not install the WD smartware/settings stuff.

Looks like it might have to be a store return and go for a different manufacturer…

It may very well be the VCD. Look for Elements drive it is plug and play with no software or VCD,


1 Like

I was reading some other posts about disabling VCD so tried downloading and running the Virtual CD (VCD) Manager, it errors saying ‘Please connect a WD SmartWae drive to continue; then click Rescan’ - when the drive is connected.

I’ll see if they have the Elements drive when I have time to get to best buy to return this. Thanks.

I have the same problem  

PS3 only can read the first partition

is there a way to find and delete the hidden partition

WD Passport Essential SE or other Passport external devices (with security built in) are not design to work with PS3 units. They are essentially data backup devices with security and are not performing well on high speed data transfer requirements.

 This is due to the fact that all data written to disk are encrypted and data read from the disk are decrypted as they coming out of USB port.

And most of all these drives needs sleep in between data transfers and continuous ON duty cycle is not ideal. (Makes their life span shorter)

IMO, drive data encryption is full time active even if user does not set a password lock. It is transparent to average user as it mealy uses the default hardcoded password to encrypt & decrypt data. This is evident on many complaint made all over the internet regarding their slower performance even on USB3 mode. (Personally I have witnessed many non branded USB2 drives performing well (Data Read/Write) over My Passport Essential SE 1TB which I own)

I personally do not advice reformatting large drives with FAT32 format (just to make them work on systems like PS3) as this 32 bit file allocation table is not that fault tolerant as NTFS.

FAT32 formatted Passport drives loses its file integrity over a period of week or months time creating bad unreadable sectors all over the disk. (We can see many evidence even on this forum and how hard is to recover a Passport drive when it gets non-responding due to file corruption situation)

Mabikay - SLK

Hey i have the exact same problem, did u end up fixing it? please let me know asap

hey did u end up fixing the problem

I bought the WD my passport essential SE and it will not show up on ps3 neither will the light on the hardrive once pluged into the ps3… will it ever work or should i return it and get a different one?

Just a friendly advice…

If you need to expand your PS3 data storage, it is always advisable to get a simple USB drive (even unbranded enclosure with any brand of bare drive) with several hundred GB(s). As you know already, PS3 requires FAT32 file formatted drive. On top of that partition needs to be created on a logical drive structure.

My Passport Essentials SE is not designed to work in this way. You can format your WD drive to FAT32 using third party formatting utilities. But most of the time you may not able to take the full advantage of MPE-SE large capacity. Since the drive is not designed to work in this way, it may become corrupted and unresponsive over time. And you cannot copy files larger than 4GB (3.99) to FAT32 partitions.

As I said before, it is always good idea to buy a separate smaller drive to use with PS3. My Passport Essentials SE comes with “unnecessary tools” such as Virtual Drive (VCD) Hardware encryption, Hard coded energy saving modes and NTFS file system for your “PS3 application”.

I hope this is clear enough you to understand your current situation.   

I know that this post was well over 2 months ago but how stupid is it that you have to have your hard drive formatted it a out dated file system, fat32 went out with the old millennium… get with the program play station! am I wrong… if anyone disagrees pleases let me know

PS3 explicitly work on FAT32 and no other file format supported.

As already said the main problem with this drive is the VCD partition, which is a PERMANENT 1st partition.

If your PS3, XBOX, Video player with USB,PVR etc is not able to “read” past the 1st partition there is no way to use it.

It does not matter the format as long as your “machine” will not be able to “read” that (2nd,3nd etc) partition.

ignore all other posts its true u need to remove the pass and format it to fat32 but other than that u just need a powered usb hub to support the drive’s power cause ps3 doesn’t

the drive works flawlessly

You are 100% right. I spent the whole weekend trying to get my ps3 to pick up my passport and nothing worked. I noticed that the LED light was not coming on but I could feel it running. So I got a powered USB hub for $ 20.00 (on sale) and sure enough it works!  

Also I used a program that was referred to me by western digital support line called fat 32 formatter to convert the the HD to fat 32 which also worked great. Good luck