My Passport Essential SE 750gb crapped out while doing a backup

I was backing up some data yesterday to my Passport Essential SE 750gb.  I’ve had it for 13 months, this thing has never been dropped…cable seems in perfect condition.   While using Acronis True Image Echo Workstation to back up some data, which I done many times without issue, I noticed an error from Acronis about unable to backup a file.  I hit ignore/cancel, and got the error a few more times for subsequent files.  I then realized that something was up with the Passport drive.  This is where I’m at now.  When plugging the drive in the light comes on like normal and the drive spins just as it normally did, but it is not detected by Windows.  It does not show up in Disk Management.

I’ve tried the WD “Data Lifeguard Diagnostic for Windows_1.22” with no luck.  

I have tried hooking the drive up when running  Knoppix v6.4.3 and it did not detect it.  I just used the disk manager program to check for it and it didn’t show up.   I’m fairly certain my data is still on the drive, but maybe some sectors are bad.  Any advice on how to fix this thing?  


Let’s try some troubleshooting.

  • Connect your drive into a different computer.

  • Replace the USB cable

  • Connect the drive into a different USB port.

  • If you connect another device to the computer do you experience the same issue?