My Passport Essential SE - 1TB

Hi. i have recently buy one of this HDD, but im having a big problem. I already have one of this but the other model, the older one USB2 and wiht 500GB, great HDD, so now i buy the new, the one that its USB 3.0 and 1 TB. Everything was great until today…i cant take the files out of my disk, or see they properties, i tried it in 7 different computers. I can see the files, if its a video i even can play it, BUT not all of them, for example a RAR cant be open, just hang everything or if i make right click it freezes all…i can add things to the HDD but i cant take them out (copy to the PC again). I have make a lot of diagnostics with differente programs but they couldnt complete the test. When i try to make a chkdsk it freeze and never completes and after a while thats its running the chkdsk the HDD reappear at windows like i just plug it in (but it was already plugged). I use check the disk with a program that i found here at the forum, a program called Crystal Disk Info and it says “Caution Current Pending Sectors Count”.

Well if someone can help me up…i have travel to the EEUU for christmas and buy the HDD, but im now back in my country, if i was in the EEUU i would change it for another one that its working -.-

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

If you are unable to get help from WD, read this post. It might help you to restore your drive.

Good luck ,

Mabikay - SLK

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. …