My Passport Essential SE 1GB not working

Hi, i just bought a Western Digital My Passport Essential SE 1TB  and i keep getting a “usb over current error” when i plug it into my dell desktop. now from what i could gather i get this error because my usb 2.0 ports aren’t providing enough power, but the thing is, my ports allow 500mA of power to go through them, which is enough to power the drive, so my question is, why isn’t my hard drive working? before you ask, yes i’ve tried every port on my computer, and i’ve also unplugged every other device and tried it and got nothing, no movement on the drive or anything. i am also using the cord that came with the product. its not showing up in device manager or disk management or anywhere else. when i plug it into a port the whole port stops functioning.

Please answer!

*Edit- It’s a 1TB drive, not 1GB

Can you try the drive on another PC and eliminate the possibility of a bad drive? These drives are extremely sensitive about power. A lot of PC makers use really wimpy power supplies. Personally I don’t like USB powered drives.


i tried it on a laptop and it didnt work on that either, i also tried it on my tv to no avail.

If it doesn’t work on another PC it’s probably the drive. I’d return the drive from where you bought it.