My Passport Essential Not Responding And Has 2TB Unallocated Space ...Please help me

I am running windows 7 Ultimate. yestarday I backed up some project files to my harddrive like before and I remove the hard drive and switch off my laptop. When I tried to access the passport the following day it wasn’t recognised by the laptop.

and it show’s 2TB unallocated space in Administrative Tools > Computer Management … and it  be heard spinning up and down for about 30sec but autoplay does not pop up on the laptop screen. The drive shows up in device manager as ‘WD My Passport 07A USB Device’.

i brought this hardrive last february in malaysia…, i’m from srilanka so dificult to claim worranty.

P/N : WDBAAA5000AWT - 00

S/N : WXK0AC9X6169 

Please guide me to solve this problem becouse last week i backup everything in my old laptop to this hard drive almost (400 MB) .net project files document  …

Try this link, it has worked for me how to error-check your drive. I did it once and it fixed everything!

Let me know if it works!

Hi,  Is it working now?  I do have same problem with my Passport Essential SE. 1TB.  I bought it in September 2010.

I am also running windows 7 Home edition upgraded version from Vista on my laptop HP Pavilion dv3. Yesterday I saved my pictures and music to it. Today when I tried to access the passport, it was not recognized by the laptop.  It can  be heard spinning up and three clicks then shut down after about 30sec but autoplay does not pop up and the light did not blinking. 

Please advice how you fixed it?

Same problem here including the head spinning with clicking sound followed by stillness.  I’m not finding any indication that the drive is being seen by my computer as anything though.  Not sure if you are seeing this as well.  It is also the 1Tb passport essential.