My Passport Essential is no longer recognized on Win 7 PC

Recently my Passport Essential is not recognized by my PC.  I tested on a separate PC and received the same results. At this point it appears the drive needs to be returned which I now have an RMA. Any ideas on how to destroy the data on the unit prior to returning the product? I know it sounds crazy that if I cannot access the drive I cannot get to the data to destroy but thought I would ask the obvious.

Not possible, however have returned drives in the past and WD is very strict about this

check this article

1 Like

I have the same problem, recently bought MyBook network external drive and sent everything from My Passport essentials

to my new network drive - its sweet and easy to use and can access anywhere (so I’m told - I’ve yet to try it)  I then re formatted My Passport Essentials did a back up of my lap top. Today I plugged it into my laptop and there was no usual bleep,bleep to let me know its been recognized and it is normally there to see in My Computer in (E): drive listed as New Volume - but it is not there.  I have since searched for this problem and it seems to be very very common indeed.  I’m now not sure if I should have bought yet another WD product.  I’m glad I formatted it if I have to mail it back and pleased to know about WD’s strict rules, fortunately there was not much on my laptop back up and not bothered if its lost. (oh lucky me hey - but sorry about your predicamet bwestein I would be pulling my hair out by now.)

1 Like

I bought a new WD My Passport 1TB and it did not function on 3 different computers. 2 of them with extra power supply to the USB 2.0 ports. 1 without. It just connected a few minutes and then disappeared. Or it could copy a small directory back and forth when testing but then gave up. I tried around 20 times on these different computers but the drive always disappeared after a few minutes at best.

I went to Low Yat SRI Computers Service in Kuala Lumpur since I boght the drive there and it was under warranty. The service is located where they sell network solutions, ADSL modems etc. and the drive functioned like a charm. No problems everything perfect. Both on USB 3.0 AND USB 2.0. Took back the drive, went home, tested on my same computers with different USB ports but nothing worked direct and through multiports. My other external drives all work without problems. The old external drives all work if I use extra power on USB 2.0 multiports but the new My Passport just disappears after a while or gives read error messages.

The problem I think is in the way it is factory formatted. It could be used without any problems whatsoever on SRI Computer’s rather new service machine. It had Windows 7 or higher. At home I just use Windows XP and Windows Vista Business and I use older machines.

I was desperate and had no important data on the drive so I downloaded all VISTA drivers to the drive (3 different) on a Windows Vista machine. Everything installed on my Vista machine. Tested again, does not function more than a few minutes. I FORMATTED IT! (not quick) on Windows Vista. Since it took forever with 10% ready after 2 hours I stopped the formatting. After that the drive gave the message that I was not having enough user privilege to even read the drive after the failed formatting. I had logged in as administrator. There is nothing higher. Had to restart the machine and the machine could be formatted with Quick formatting instead of the slow formatting.

Lo and behold. The quick formatting took 5 - 10 seconds and the drive was as new and perfect on all 3 machines and it has now copied over 500 GB to it without any problems whatsoever.

Advice which might help:

**1/ You have to use a machine with high power to the USB ports preferably  a multi port that has extra separate power supply to it or a machine with minimum number of other USB connected gadgets. (You cannot use multiport solutions even with extra power on USB 3.0 only on USB 2.0)

2/ If you have data on the WD My Passprot try and try and try until it succeeds on different machines with other operative systems, not Win XP, not Vista preferably Windows 7 or better.  Possibly as new machines as possible and with as few USB gadgets attached as possible.

3/ If you don’t have data on the WD My Passport or if you have succeeded to make a backup FORMAT the MY Passport drive, which will take perhaps 20 hours. I interrupted my formatting after 2 hours and restarted the machine and quick formatted it in a few seconds.**


Mine works perfectly now. Copied around 500 GB on to it without problems and usable on at least 2 machines it did not work on before.

Hi i format my wd passport hard disk and it has erase all the wd drives file. now when i plug it on to my computer it says it has no files and appear on my computer as d drive. and not as wd passport like before. can i download the drives needed to use the hard disk and where can i find them to download?

the hard disk was not working properly for a while now. when i download files they get all jumble up.

pls help.