My Passport Essential firmware failed


#1

Firmware update failed and hung while installing… Sat there and didn’t do anything after it got about 70% through the process for almost an hour. Drive is not recognized and unable to load or retrieve any of the files or documents off the drive at this time… I have access to do whatever needs to be done on an Mac and PC… 

HELP ME PLEASE!


#2

Hello,

Someone might be able to help you better if you can provide more details about your computer and WD drive:

What version of MAC 10.4, 10.5 or 10.6 or PC win7, Vista, XP…?

WD My Passport Essential 320GB, 500GB, or so on ?.

How long have you had the WD My Passport drive?

Which version of the WD firmware you are trying to update to or name of the firmware file or release date ?

Suggestion:

Try download the firmware and update your WD drive from a PC windows machine.

Windows PC running under 32bit OS seems to work better than 64bit with firmware updating.


#3

OK thank. Lets see if anyone can help… Ive tried just about everything I can think of. The firmware update actually broke two of my drives as I did one after one and didnt realize the second one was f-ed up until after I posted this…

I own a Mac Book Pro running 10.6 as well as Window 7 on Bootcamp and VMware…

It was a WD Passport Essential 1tb drive

I have had it for about 4 months, it is still under warranty but I could care less about getting a new drive, I want the data I had on here back.

The Firmware version was v1.0.0.16(2.003) on my Mac OS and I have also tried the Windows version upgrade as well.

I plug the drives in and it will sometimes appear, sometimes not, and if i try to access any of the files it will hang for a long time. Ive thought of trying to change out the logic board, has anyone has success with this for far? I NEED these data files back and I dont think I should have to pay for a data recovery company to get them…

Give me any input you have and I will try… I am an IT Manager and have multiple resources available to try to get this data back… Thanks again!


#4

Have you update the Firmware v1.0.0.16 (2.003)  from a PC windows computer?

If no, please try it.

If yes, still fail, files not found or drive not recognize.

Then, it is time to contact WD tech support.

FYI: a friend of mine has a WD My Passport Essential 1TB drive also, he downloaded the firmware updater for Mac  from this link  http://www.wdc.com/wdproducts/wdsmartwareupdate/utilitiesstep1.asp?id=wdfMP_SEEssential&os=mac

then updated it to v1.0.0.16( v2.003), it went fine. MacBookPro 10.6.4, all files and partition are fine, can read and write to.