My passport essential 500gb


#1

Hi all…

Im not the most computer literate so plz forgive my simpleness:)

I have a MY PASSPORT ESSENTIAL 500GB External hard drive and am wondering why all of a sudden now when i plug it in to the usb on my laptop or PS3 i cannot read any files off of it??

I plug it in to my laptop but it doesn’t show up in ‘COMPUTER’ when selected from the start button from the taskbar under ‘Devices with removable storage,’ yet in the task bar down the bottom right where all the small icons are when i go to ‘Safely Remove Hardware’ it is visable there but only as ‘Safely remove USB Mass Storage Device,’ when previously it would say ‘Safely remove USB Mass Storage Device - Drive(G:)’.

I’ve tried changing the cable that connects it to my laptop, but it still does the same thing. When you initially plug it in it seems to start up with the various noises it usually makes but then it just stops.

All USB Ports on my laptop are working fine and can read various other external drives except this one…

Is this a common problem???  Have I or am I doing something wrong??? Or im thinking the product may be faulty and may need to take it back to the dealer i purchased it from???

Any informative help would be very greatly apprecited!!!

Thanks very much

the simpleton

PauliE


#2

My WD Passport has just done exactly the same thing. It switches on, power is there but the PC only recognises it as an external drive and not as a WD Passport etc. Neither can I access the files on it.

I fear the worst.


#3

I have two Passport Essentials and both of them are doing the same thing.  Suddenly my computer cannot identify them.  The cable is fine, the USB port is fine (they both are working well with other hardware devices that I have).  Can someone from WD please tell us what to do???


#4

couple of questions:

are you using a usb hub?  If so, connect the drive directly to the computer.

are you using the correct usb cable for the drive?  If you’re using a cable longer than 18inches it won’t work.

have tried another usb port?

thing is, if the passport works on another machine, then it’s something having to do with that pc.


#5

Mine is always plugged in directly to the PC on a short cable, it has worked fine but suddenly just stopped yesterday.

I presume its terminal?


#6

Hi I am not too clued up on these very much a simpleton too but I find it quite easy to use have you tried cicking the “WD smartWare” and do you have the hd on a time mine was on a 10 min wich was a pain as had to keep logging in


#7

Mine does the same, this after someone connected it to a Mac.  Now any PC I tried does not show it in My computer.  Hardware management sees it and Add Hardware Wizard says it is working properly.