My Passport Essential 500GB not responding, Please help

I purchased WD My Passport Essential 500GB SN [Deleted] from Saudi Arabia in Dec 2009, It’s operating was really very smoothy without interruption till last week when I tried to format it manually, it took long time to format but when the formation was nearest to complete 95%, my system hanged, then I disconnect it from my laptop and connected it again…but uff…it’s not showing at all, only showing Firmware directory (F:), I unlock it with password then take longer time to scan it then showing hard drive directory (G:), BUT IT DOESN’T RESPOND after click and finally get stuck with computer, it hanged, I took it to 4 workshop to reformat and make it existing the directory to operate, but everywhere technician shown me handsup, they can’t solved, the only option is to purchase a new one and throw it in garbage…but I hope a little from WD Community, can anybody help me to solve this problem so that I can make my WD My Passport Essential working again like before.

expecting solution.


Try writing zeros using DLG. Check the link below for the steps.