My Passport Essential 500 Go USB 3.0 doesn't work

Hi everybody,

I bought last week a My Passport Essential 500 Go USB 3.0 and I have some problems to make it working…

It worked only one time, the first time I pluged it in my computer.

Now when I plug it to my computer It doesn’t find some drivers like SES drivers sometimes but or windows says me the HDD is unpluged although it is.

I think it is not a driver pb because it worked the first time I plugged it to my pc…

However I moved some files  which was in the HDD at the beggining and I put them in a folder I created, Is the problem coming from that ?

Please help me…

Can you move those files back to the drive, I think that could be the problem. Also have you test your drive using another computer?

If you wish to use your drive with WD Smartware, you can download the files that go in to the drive from here:

But I you do not wish to use Smartware but you want to stop Windows asking SES driver, you can download install SES driver from here:

Mabikay - SLK

If you need more info on drive troubleshooting please read this:

Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue. …