My Passport Essential 400Mb Problem- Please help me!


#1

Hello, I have a 400Mb My Passport Essential which I was using on both my PC and my Mac fine until it started behaving very badly. Basically when you plug it in, it spins up and you can see the files on it for about 5 seconds at which point it clicks quite loudly (once), and then the computer (PC or Mac) behave as if you just unplugged the drive. Then it spins up again and does it again.  On a mac, you get the “Device Removal” notification, and the same thing on a PC. 

This drive has some very important data on it that I want to salvage. 

I tried updating the firmware but since the computer only recognizes the drive for a few seconds, this doesnt work. Also, I tried using a mini USB to dual USB lead to give it more power. In any case, it worked fine before, so I cant see that this could be a power issue. 

Can anyone out there help me? Im tearing out what little hair I have left!


#2

It looks like your drive enclosure is the issue here. If you really need the data of the drive, there is always data recovery companies, they are expensive, but it is route that you can take if the data is really important.

http://support.wdc.com/recovery/index.asp?lang=en