My Passport Drive Suddenly Not Recognized in Win 7 64 bit

I have a  that is a couple of months old and worked fine through last Thursday.  When I connected it to my HP laptop this morning, I could hear it cycling and then making a “bip” sound - over and over until Windows said there was an error installing the hardware.  It is a [Edited for privacy - Trancer].

I have:

  • Tried different USB ports on the laptop and dock.
  • Used a cable from another recently purchased WD My Passport external hard drive
  • Tried removing it from Device Manager and reconnecting it
  • Updated the driver with the SES one I downloaded from WD
  • Tried to use the WD Dirve Utilities (SMART Status = failed, either of the drive tests stalls)
  • Tried the same drive on another laptop - same symptoms
  • Checked in Administrative Tools, Drive Management - hard drive is listed as Hard Drive (5) and will not initiate.

I currently see WD Drive Management devices, WD SES Device in Device Manager, but only “Disk drive” under Disk Drives.  I don’t see a drive letter for it in Windows Explorer. I can eject it (where it is referenced as "My Passport 0748).

Help!  I would just as soon not loose the work/information on this drive that has not yet been copied up to our servers.


Try running a diagnostic using Western Digital’s Data Lifeguard Diagnostic tool in order to verify if the drive is defective or not.