My Passport does not work

Model WDBAAA3200ABK-00  one year old.  Update worked find till the last update a week ago, now I am unable to get it to do anything.  When I check it either in my computer or computer management this is what I find.

(E:)  WD SmartWare  free space 0 bytes - total size 614 MB - file system UDF

(F:)  New Volume - used space 83.7 MB - free space 297 GB - file system NTFS

Computer management show the same thing plus E & F are healthy

If I click on the Smartware icon nothing happens.  Not sure about what is needed to fix this problem, and search has not helped much either.  Prior to this when I plugged it into the usb I could access the WD program and back up my info. Could I have deleted a program from my computer or the drive?

OS - XP Home sp3  system dell e510.


It seems like I’m having a similar problem. As soon as I updated the firmware and software of My Passport it doesn’t register or work anymore, the drive itself is working but it’s just not working somehow. I hope someone might be able to help us BlueJay! Cheers.

hastroubledeed  -  I was able to fix mine last night.  If your drive shows the same info that I listed in my post, all you need to do is follow the two (2) steps for the product update.  I am sure you can find the info on the WD site.  That means in step one you must update the drive firmware by downloading and extracting the files and updating per instructions given.  For step two you must have Microsoft Net 3.5 framework installed on your computer, then download WD SmartWare Software updater to your hard drive and follow the on screen instructions and the steps in #2.  I followed the instructions and was able to access the software and backedup my passport drive.  I am not sure if I missed the second step in prior tries and that was my problem.


This thing has to be a joke.

I have My Passport.  Less than one year old. 

I plug it in.  It shows in the device manager.  But it does not autoplay.  I cannot use it at all. 

Tried it on two other computers.  Same thing.

It’s got very few documents on it.

Is this thing just a piece of junk?  I think so.

Many users have reported similar problems with drive recognition and they’re due to a number of reasons.

With my Passport Essential I bought it to back up my files before reinstalling vista due to non-booting PC. When I booted from a bootable virtual drive XP cd the Passport installed perfectly so I backed up my files but once I installed and ran Vista what happened was Passport showed under device management and disk management but not under my computer. Also under disk management it showed the file system as “RAW,” which was strange because it showed as NTFS in the XP environment.

Turned out to be a file permission issue and solved by resetting permissions.

This might work for you:

Not sure with windows 7 but with Vista right click “my computer” and select “manage.” When computer management comes up select “disk management” from left panel and  right click the external hard drive (should show) and go into properties, then under “security tab” set permissions to “everyone.” With XP or  7 the process should be similar. 

If this doesn’t fix it then you might want to reassign the drive letter.

These pages should have a solution or you: