My Passport - can't read my files

I purchased a 500gb My Passport just 3 months ago and created a new folder for my back up files. Everything worked fine until 2 weeks ago. Now my PC can see the external drive but my folder of files is not shown. Sometimes when I connect it comes up with the message do I want to re-format, which I don’t. Out of desperation I tried connecting to a friend’s Mac and miraculously it could see my folder and files. So why can’t my PC (running Windows 7) see my files? How do I fix this?

i tried connecting my passport 730 to a mates Mac and it didnt work any better, but it sounds like mine is having a similar problem to you. i hope theres a way to fix this problem.

I don’t use the WD software, I just use it is a storage device. My PC can see the external drive and when I go into Device Manage it says that the ‘device is working properly’, so I cannot understand why my PC cannot see the folder I crteated with all my files … when someone else’s Mac can.   

1 Like

What OS are you using and how is the drive formatted? For Windows it needs to be formatted NTFS, that will be read only on a Mac. Does the drive show in Disk Management and what does it say there?

Joe

Hi Joe 

I’m using Windows 7 but I’ve also tried another PC with XP and it cannot see the files on either PC. I don’t know how the disk is formatted, I just use the drive to drag and drop files into a separate folder I created. This has worked fine up for several months but now it cannot see my folder. The drive light is on and I can feel the disk is spinning. Attached is a screenshot of what I see on my PC.

wd.jpg

The pic hasn’t been released yet. I’ll look back later.

Joe

Q: What is the point in buying an external hard drive if you can rely upon it ? A: None whatsoever!

I contacted WD customer support over this issue and the best they could come up with was to either:

  1. Re-format the drive, and thereby lose all, my data, or

  2. Go to the Community Forum and see if there was a solution there 

I’ve since found loads of threads on the internet with users having exactly the same issue as I have had, yet WD does not appear to be at all interested in fixing this problem, maybe they simply can’t fix it.

Like many other users who have experiencede the same problem, I am that frustrated with WD that I have now bought a Seagate instead. So mjy advice regarding WD external drives is …   don’t buy one!