My Passport beeping noise [Mac-based]

Hi! Just need some help.

First off this is my exact WD EHD at 1TB. It has been reformatted for Mac and I’ve followed the guidelines on the site when doing so. I’ve had this for nearly 2 years already. All parts original.

It’s happened to me more than twice that my Macbook Pro (Lion) is unable to detect it, causing me to plug and unplug the thing until it detects it again.

Today, I had it plugged while I was converting some videos and directly saving those into my plugged in EHD. I was about 2 videos in and then a bit later on, I realized that my conversion stopped. So I checked if I can access the drive in Finder but no such luck. I went to the Disk Utility and again it doesn’t recognize my drive. What I did was restart my computer but still, I’m unable to detect it and the beeping noise startedd. So I switched cables with another WD HD (500gb) I have with the exact same and original cable. It doesn’t work, the beeping noise continued. I restarted again, no luck.

I googled some stuff but it all involved downloading a 3rd party application. I’ve never had this problem before. Most of the time it’s just unable to be detected and after a few tries of plugging and unplugging the cable and/or restarting my laptop, it works again.

Also, my 500gb EHD is being detected and recognized by both cables I have. Does anyone have any idea how I can solve this? Would be appreciated! Just have some really important files on my EHD like I’m sure the rest of us do.


Just for troubleshooting purposes try connecting the drive to another USB port (a USB on the back if possible), Also (if you can) try another computer. It is possible that your computer is not providing enough power to spin up the drive properly. 

If this does not work and you are still not able to see your drive in Disk Utility then I recommend you contact technical support directly.

General Phone Support

Thanks for responding! I’m using a Macbook Pro and I’ve tried both ports and the other cable I have for my 500gb WD (same cable type) and still no luck. I’ll try to see if the other Macbook I can use can read it, otherwise, I’ll try calling them when I get the time. Thanks again!