My Passport access hanging/freezing

I’m trying to fix a My Passport for a friend (not sure exactly which model) and whenever I try to connect it to my computer it I can’t properly access it. If I try to ‘scan and fix issues’ on connection it reaches about 20% before essentially stopping and when I try to view files it either causes my file explorer to stop responding or take incredibly long times to check anything.

Does anyone know how to fix this so I can access the hard drive properly?

Those symptoms aren’t a good sign. Is it making any kind of clicking sound?

What happens when you run Data Lifeguard Diagnostics for Windows on it?

Have you tried it on a different computer with a different USB cable?

It’s not really making a clicking sound at all, no.
As far as the data lifeguard diagnostics goes, the drive shows up on the logical drives, but it is not showing up (I think) as available for testing on the physical drives box.
I have tried it on a different computer; the same issue occurred. Unfortunately I don’t have another cable to try it with so I can’t test that.

OK so you’ve ruled the PC out as the problem, so that leaves either the drive or the cable as the cause. See if you can’t dig up another cable somewhere (you may also be able to buy one for a few dollars). Based on the limited amount of data we have available to us here, I suspect there may be physical damage to the drive but I’ve also seen “false positives” when the drive is used with a bad cable. The fact that there is no clicking is a positive sign that this could be the case here so I really would like you to see if you can’t track one down.

We use standard USB cables for our drives for just this reason - they are used on all sorts of devices from mutlimedia players to (non-apple) cellphones. Hopefully this will help you find something to use for testing.

Ok, I’ll try and see if I can get hold of another cable and see if that helps at all.

Many thanks.

Hi again,

I managed to get hold of a new cable for the hard drive and it is still not accessing/transferring the data properly. After trying to transfer the data again with the new cable, I have a noticed an odd sound which sounds a little like beeping from the hard drive. Does this suggest there is physical damage then? If so, is there any way of recovering the data?