My Passport(Access Denied)

Hey WD Community,

I am having a huge problem with my WD My Passport 2 tb(WDBAAA5000ASl - 00). It is one of the old ones that I have had for years. It worked once,but after that it stopped. Now here are my problems… 

First of all, I can’t see my passport anywhere under my computer. Second, I can’t initialize my disk because it keeps on saying “Access Denied”. No, I do not have my old computer so I can’t change the security settings. I also can’t change the Drive letter because I need to initialize it to do that. PLEASE some body help me reset it and I don’t care if I lose all the files I just want my driver back. One last note, whenever I try to firmware update it, it wouldn’t let me, it would say “Firmware update failed on specific drive WD” so I can’t do that either. The firmware is from 2006! If anybody could help me, that would help alot. 

Have you tried using another USB cable to connect the Passport? Be sure to connect the Passport directly to your PC, avoid using USB extension cables or USB hubs. The problem could also be related to data corruption, if that is the case you can do a quick search on Google for several data recovery programs you can use. You can also contact any of the data recovery partners on the WD support page, some of then offer a free evaluation of your drive. Check the link below for more information. 

Data Recovery Partners

Hey Ichigo,

Thanks for the reply but the thing is that I don’t mind losing everything on it, I just want to be able to use it again. Is there anything at all I can do to fix this? And yes I am tried another usb cable so that doesn’t help either.