My Passport 730 not recognized

It seems I am having a problem similar to many. The other night, passport was working fine. When I finished working, I safely removed the drive. Next morning, I head to work, plug in my passport and it isn’t recognized as a drive on either my laptop or desktop. The light is on, it definitely is getting power, I can feel the drive running, but, that’s it.

If I open the device manager, it lists it, but I cannot access it. I have to be able to recover the data on my passport. The passport is only 3 weeks old and as soon as I unplug it, it goes directly in the box it came in, and has never been dropped, etc.

Please help me figure out how to get it working again.

Thank you.

It sounds like it got corrupt that can happem using on more than one computer. Does it show in Disk Management and does it say anything there like Raw? Something like TestDisk may restore it.  Here are some data recovery links in this post If you have all of the data off problably just reformatting would be best.


Thank you…I will try those. I do not have any of the data off of it yet. I am just hoping I can get it. I have a ton of work files on it that will be completely lost.

HELP!!! I just plugged it back in and I get a screen that says “You need to format the disk in drive L: before you can use it”

Won’t this wipe any data off of the drive?

Yes that will wipe the data out. One more thing you can try is burning a Linux Live CD boot from it and see if you can access the data that way. It doesn’t actually install.


Thank you…I haven’t tried anything as of yet. Crazy work day, the only thing new is that it is at least showing up as a device, but labeled “local disk” when i go to device manager, it says it is working properly, but is not able to provide any detailed info like model, serial, etc.

Hopefully something will work tonight. Thank you for all of your help!

hello guys, i had the same problem on saturday and i tried everything and nothing happend… the next day, i plugged it in again and after 5 min I saw that my hdd become ok. but yesterday, when I plugged it in again the same problem. and till now the only thing that it tell me its "local disk"and the only thing that i can do is to format it… after researching on the internet i found that this happens when you want to safely remove and it cannt. its because inside the drivers of the hdd some files may change… try to uninstall all the usb drivers from the device manager and then download the wd ses drivers… for me this was the solution at the first time… but now its not working… if someone knows something pls help!!!