My Passport 500GB drive: Access is Denied message when I plug it into another computer


#1

Hi there,

I have a WD My Passport Essential 500GB external USB hard drive. I have been using it to back up files on my laptop for a few months. Now, I have a new laptop, and I am going to use the My Passport drive to transfer files from the old laptop.

When I plug the MY Passport into my old laptop, I can access it through drive G: in windows explorer – it looks like a regular drive. However, when I plug it into my new laptop, it shows up as drive E: and when I double click on the E: drive, I receive a popup saying: “E:\ is not accessible. Access is denied.”

Note, I actually have two new laptops (one windows XP and one Windows 7 64-bit ) and my old laptop is Windows XP.

Why? Seems like there’s a problem here.  

Please help!!

Cheers,

Don


#2

Well, I figured it out on my own I think.

Apparently the problem has to do with some sort of a permissions problem.

All I want to do is use the WD external drive like a big USB flash drive … plug it in and copy files to it … but, alas, it has some security “feature” which assigns permissions and ownership to the drive and folders you copy to it.

So, here’s what has to be done as a workaround:

on the computer which shows the “access is denied” message,  follow the directions on this page:

http://support.microsoft.com/default.aspx?scid=kb;en-us;308421&Product=winxp

This link shows “How to take ownership of a file or a folder in Windows XP”

you basically do the following steps:

  1. Disable Simple File Sharing (Start --> My Computer --> Tools --> Folder Options --> Vew tab --> Advanced Settings --> uncheck “Use simple file sharing” --> click OK

2)  My Computer --> right click on the drive (e.g. F: ) --> Properties --> Security tab --> click OK if security message appears --> Advanced --> Owner tab --> in the Name list, click user name or Administrator --> select “Replace owner or subcontainers and objects” check box --> click OK --> click Yes --> click OK

If this is not right, please let me know.

If this is right, I hope it helps someone else with the same problem

Cheers,

Don


#3

THANK YOU – this was very helpful and I was getting EXTRA frustrated with this issue!!

Thank you for posting this!!
Meghan