My Passport 1tb not recognized properly


Overall I was very satisfied, but now I have a big problem with the disc. It is not recognized properly by any computers and it seems I have lost all my 15GB information (unless there is a way to fix my problem).

It is recognized as local (not removable) drive with 0 bytes available. It can not be defragmented, formatted or anything else.  I have tried with some different sw to fix this. In some cases software did not detect the disc at all, in other cases software detects the disc but cannot read from it. When the disc is detectet, it is as logical, but not as physical device. 

Problem occurred after shutting down my office pc with the disc plugged in (it usually stays connected to my office pc) When I got home and tried to open some info at first all folders and files were there, but soon after everything just vanished, autorun didn’t work and the disc properties showed 0 bytes.

Anyone experienced the same problem, or any ideas how to fix this?


Sorry, but it looks like you have a faulty drive, try to contact WD support and RMA the drive.