My Passport 1tb not accessible


I got a problem with My Passport 1tb, it used to work fine now it stopped working.

I searched the net for solutions and nothing helped. 

the symptoms are: 

-I plug it to usb and win7 make a plug in sound.

-no auto run or any open option work. 

-in my computer it appear as F: when i try to open the drive it takes few seconds and then i get the “F: is not accessible”

-WD My passport is shown in device manager-> disk drives BUT when i try to locate it in Disk Managment the whole application just FREEZE! 

  • when i unplug the drive from usb windows pop up message “you must format F: to use it” (or smth like that), and even when i tried to format it when it was plugged everyting freezed or “not responding”

I tryed it on other laptop and nothing. also tryed testdisk 6.12 

Im sure the hardware is fine. the white light works and i can feel it working.

Probably happand after i unplugged it without safe remove or in the middle of data transfaring

I spent the whole day looking for solutions PLEASE HELP! 


Please run the Western Digital DLG application, you can also write zeroes to the unit with the tool. Is available for download at


I tried the application, unfortunately the app crashed when the drive wasplugged(my passport), works when it doesnt.

when I tried to open the app first and then plug the drive, it wont recongnize it.

frustrating… any other ideas? please.