My Passport 1TB no longer mounts!

I don’t even know what happened, you guys.


It was working fine, and now it’s not.  


I have it partitioned into four partitions of 500 GB each… one for my Time Machine, one for my husband’s TM, one for my “stuff”, and one for Hubby’s “stuff”.


None of this will mount.  Disk Utility can’t see it.  DiskWarrior can’t see it.


When I restart my MacBook Pro in Windows 7, the drive appears under “Printers and Devices” and is allegedly “functioning normally”.  But it’s really, really not.


Please help!! :crying_cat_face:

You can hope for the best and try a different USB cable or a different computer.

I had the same problem with my WD portable. The drive worked fine for a year and one day it was not recognized without any warning. I tried everything from a Linux boot Live CD to opening the drive and switching the PCB and BIOS with another drive of the same model. I consider the drive a total loss and my data is gone.

There are data recovery services that can attempt to get your data back, but they are very expensive.

I’ve tried it on another computer, and still no luck.


Ugh, I’m sorry you lost everything.  That looks like where I’m heading now, and some of that stuff is irreplacable.  And I don’t have $$$ lying around to pay for data recovery!

I have the same problem :frowning:

My WD is only 9 months old and it stopped without a warning. Now everytime I plug it, drive motor tries to run and after a few clicking sounds it stops and starts beeping. I was thinking to buy another one and change the PCB eventhough I am almost sure it is about the read heads. I dont want to give 300$ for my archived data which I am not even sure how important they were (I will when I need them I suppose :)).

But as I read above that PCB changing will not be effective as I was afraid to be. 

Isn’t there anything that we can do to change some parts of the drive like read heads from a working one?

How clean should the environment be to make that change and not corrupt the disk totally, do you know anything at all?

I am willing to sacrifice my right for RMA and even sacrifice the second one I am willing to buy?


Ugh, what a nightmare!


I’m not going to take it apart, because I’m pretty sure that would void the warranty.  Also, I really have no clue re: surgery on a hard drive! :stuck_out_tongue:


At this point, I’m just hoping to recover my files, but I’m starting to think that’s not going to be possible either.  This really bleep!

I have the same problem. In my case the password unlocker successfully unlocks the drive but when you click on the opened drive it tells me that it needs formatting. All my years work is on it!

Tried all sorts from firmware update, WD support told me to try low level formatting but now its coming up with too many bad sectors and wont complete even full formatting. The work is backed up but the drive is useless. I can’t even format to reuse.

At least your stuff is backed up elsewhere!  Still, what a pain.


I may try calling WD support, but I’m really not too optimistic at this point.  I’m sure I’ll have them replace the drive, but I doubt I’ll buy another WD drive in the future… I’ve seen too many similar stories here! :crying_cat_face:

I am off to buy a new one. I will not buy Western Digital again.

This is my second drive that crapped out on me.

**bleep** lucky I can get the files back.  **bleep** lucky!

How are you getting your files back?