My Passport, 1TB is not getting detected on any OS, only feel some spining when connected


I recently received a replaced My Passport, 1TB HDD for my previosly corrupted My Passport, 1TB HDD.

When I connected it to my laptop (win7) it was not detected at all, not even in device manager. Also I tried to connect it to my desktop(WinXP) but not good :frowning: …  All I could feel is some movement in HDD, probably disk spining.

Since this is already a replaced HDD, I was hoping WD would have at least checked what they are sending to consumers. Unfortuntly it seems that I will have to raise another RMA for this and get drive replaced… Hopefully they will send me working HDD next time.

If anybody can suggest something, please do…



Finally I had to reship the HDD back to WD…

I wasn’t expecting such kind of service. Hope they will check the HDD before shiping to their customers !

  • Roshan

The drive was dead on arrival so you did the right thing by returning 

I tried a brand new My Passport 1TB on 3 differnt machines that had the drive working only a few minutes at the most all of them. Win XP and Win Vista Business. I gave up and tried at a service center with a Windows 7 or higher machine and it worked right away for a long time both on USB 3.0 and USB 2.0 1/ You have to use a machine with high power to the USB ports which means either direct connection to a single USB port on the machine without any extension multi port solution or a multi port that has extra separate power supply to it. (You cannot use multiport solutions even with extra power on USB 3.0 only on USB 2.0) 2/ If you have data on it try with a machine having an other operative system, not Win XP, not Vista preferably Windows 7 or better. I got mine to work at SRI Computers service machine in Kuala Lumpur without problems 3/ If you don’t have data on it format it, which will take perhaps 20 hours. I interrupted my formatting after 2 hours and restarted the machine and quick formatted it. You could try to save the system files on it before you format if you can, but they are not necessary for the function of the drive unless you use a Mac etc. The quick format only took 10 seconds and now it works perfectly. But I have only tested with 500GB data so far during 10 hours