My Passport 1TB is not detected by PC

I have a 1TB My Passport (WDBACX0010BBK). I plug it in and it lights up and I can hear it spinning, but it will not show under My Computer. I have tried it in USB 3.0 and 2.0. IT recognizes the USB connection, but not the drive. Is there a place I can get a new USB cable to see if that is the problem or is there a place to take the drive to get the data off of it. It is encrypted.

Contact Customer Service and see if they will send you a new USB cable. Also don’t plug this into a hub. A port on back sometimes works better. Have you tried this on a different PC? What OS and does it show in Disk Management?

Joe

I have almost the exact same issue!

But the drive is detected on a vista laptop., and not a xp laptop (which is where i need backup for!:cry:)

Thanks for the response. I will give customer support a call and see if they will send me a new cable. I have tried it on two other computers. One is a laptop running Win XP Pro (has connected before) and the other two are computers running Win 7 Pro and it has connected to both of them before. I have tried the USB 2.0 ports, but I will try others as well.

When I click on disk management it takes a long time to load. It acts as if it knows something is out there and it is trying to connect to it but can’t. When it does show up is says it needs to initialize. I clicked that and after several minutes it shows it as Unallocated and Not Initialized. It is showing the right size.

if the hd hasnot initialized yet on then initialize it, if your problem is your other computer cant detect the hd but its running, it could be a driver issue, download SES driver and install it on the computer that has the problem…if after doing all of this and still not work, call WD to get a new usb and power booster cable…

Johnny_Greene wrote:

I have a 1TB My Passport (WDBACX0010BBK). I plug it in and it lights up and I can hear it spinning, but it will not show under My Computer. I have tried it in USB 3.0 and 2.0. IT recognizes the USB connection, but not the drive. Is there a place I can get a new USB cable to see if that is the problem or is there a place to take the drive to get the data off of it. It is encrypted.

any electronics store should have the cable.  just make sure that it’s 18inches or less.  if it’s encrypted and you have the password then, yes, you should be able to get the data off it, if necessary.

Hello,

     I am also facing the same problem. Is that only the USB cable or hard drive problem ?

Wayne wrote:


Johnny_Greene wrote:

I have a 1TB My Passport (WDBACX0010BBK). I plug it in and it lights up and I can hear it spinning, but it will not show under My Computer. I have tried it in USB 3.0 and 2.0. IT recognizes the USB connection, but not the drive. Is there a place I can get a new USB cable to see if that is the problem or is there a place to take the drive to get the data off of it. It is encrypted.

 

Windows 7

Start Menu - Type Computer Mangement - Click on ‘Computer Management’ - Window opens - Left vertical window - Look down through list - ‘Storage’ - Click on ‘Disk Management’ - Top central window shows list of drives - look for your external drive - Right -click on it -  click ‘Change drive letter and paths…’ - Click ‘Add’’- Add drive letter or path’ window opens - Assign the following drive letter - Choose a suitable letter - OK

If Autoplay is enabled it will immediately activate.

I hope this helps some people.

Hello,

   I only hear the spinning sound. But not showing the drive on disk management.

   Thanks for your quick response.

    On the Device Manager, under USB controllers which type of USB is suitable for this model (usb 3.0 version).

Thanks

Srini.