My passpor 2TB is not initialized

i get new WD passport 2 TB before 6 month ; and i take backup from all other WD hardisk which i have ( smallers 500 gb , 1 TB ) which incloud all my work my privete data for more than 10 years ):
2 weeks before i get issue of : not initialized
it was working normally before 2 weeks ( i’m using it as external backup )
when i connect it to my pc ( windows 7 64 bit ) i coulden’t find it under my compuer ;
i check disk managment and i found it as desk 1, unknown on line with out capacity !!!
when i chose it system ask to convert it to GPT or MBR ; i choose mbr first , then i/o error came ; then i choose GPT same error appear
i tried diskpart and i clean it , but when try to convert it i/o error came also !!
i used thierd part software to recover it ! no use !!
any idea how i can at leaset take Hard disk and my data back whith out losing data

Initializing a hard drive wipes all the data.

Diskpart “clean” option removes any and all partition or volume formatting from the disk with focus … meaning, it wipes all the data.

Highly recommend you stop attempting to fix the problem yourself and Contact a Data Recovery Service. (because everything you’re doing is reducing the possibility of recovering your data.)