My old MY PASSPORT was compatible with both Mac and PC

I just purchased a new My Passport hard drive this weekend for my laptop. I purchased the 1TB for Mac version. I am a bit confused as to why this hard drive has to be remformatted for PC. 5 years ago, I purchased an older version of this model and it worked on both formats right out of the box. Can anyone explain this to me? Thanks.

A drive formatted for Mac is not readable on Windows. A drive formatted NTFS for Windows is read only on a Mac. A drive formatted FAT32 is usable on both but the the max file size is 4 gig. There is also software to make the drive usable on both, maybe the old computer had software installed.


I’m using the same computer. I didn’t reformat my old WD Passport either. Maybe I just lucked out or the laptop reformatted it on its own when I first plugged it into my Mac?

Older WD drives used to come with FAT32 by default. However, with the large capacities available now and files easily exceeding 4GB (a file limitation of FAT32), WD decided to default format the drives for MAC (HFS+) or PC (NTFS). That is probably why your older drive worked on both computers out of the box and newer ones don’t until they are re-formatted.

If you’re interesed, I included a link below on the limitations associated with the FAT32 file system.

1 Like

Thanks a bunch for the explanation! :slight_smile:

1 Like