My notebook doesn't detect my WD passport

Hi,

Could you pls help me. I had a WD passport drive before and I just had to plug it in and I was able to see it ect. I just got a WD passporrt 1 Tbt drive and I can see it only in my notebooks list with Devices and Printers but not as a new externel hard drive. I can not access it or send files to it. I see only my SD card… I use it on my Toshipa with Windows 7 64 bit. Pls help

nevena wrote:

Hi,

Could you pls help me. I had a WD passport drive before and I just had to plug it in and I was able to see it ect. I just got a WD passporrt 1 Tbt drive and I can see it only in my notebooks list with Devices and Printers but not as a new externel hard drive. I can not access it or send files to it. I see only my SD card… I use it on my Toshipa with Windows 7 64 bit. Pls help

What passport is it? If it’s a studio or an edge you’ll need to format it before you can use it on Windows, and did you check disk management for info on the drive? You can open DM if you do a right click on the computer icon itself and selecting _ manage _.

1 Like

Hi,

Thank you your assistance. It says only WD My passport model WDBBEP0010BBK-NESN. This should be the one http://www.wdc.com/en/products/products.aspx?id=640

When I select MANAGE  I can see it and it says UNALLOCATED. What should I do next?

nevena wrote:

Hi,

Thank you your assistance. It says only WD My passport model WDBBEP0010BBK-NESN. This should be the one http://www.wdc.com/en/products/products.aspx?id=640

When I select MANAGE  I can see it and it says UNALLOCATED. What should I do next?

 

If it’s unallocated, then right click it so windows give you the option to format it. If it refuses to format because its read-only then either the drive is bad or the password is active.

1 Like

But there is no active link for formating wd

Can’t seen the pics until approved by a mod

The options are    Convirt to dinamic disk, Convirt to MBR disk, Properties, Help

The other options are     New simple volume, Properties, Help

Images should now be visible.

Regards,

Trancer wrote:

Images should now be visible.

 

Regards,

 Thanks.

nevena wrote:

But there is no active link for formating

There you go, right click the black box and new simple volume will let you format it.

1 Like

:laughing::laughing::laughing:

THANK YOU! tHANK YOU! THANK YOU!

It’s visible now and I can try to load it :))

Thank you!

Any time :wink: