My New WD20EARX drive is not detected by BIOS/Windows

Hi There,
I have bought a new WD Green Hard disk WD20EARX. Its 2 TB HardDisk. But my PC could not recognise it. Neither BIOS nor Windows 7 64 Bit. My Motherboard is Intel DG33FB. I have three other HardDisks on my PC i.e. WD 1 TB HDD, WD 320 GB, Hitachi 320 GB. They all are working fine. 
I have read on your forums and FAQ that sometimes some motherboards does not support 6 GB/s Drives i.e ICH9 Baord. My Board has ICH9 Southbridge. So i hav tried adding Jumper to pin5-6 as per your guide but that does not work. Kindly suggest me what to do. I have even tried removing all my existing HDD’s but still not working. Kindly tell me howcan i use WDSpeed tool and where to find it. Any other suggestions are welcome.

Waiting for your quick reply

Check on the motherboard manufacturer page to see if your computer supports the drive

verify if there’s any bios updates

I have seen the intel site and upgraded the bios to latest available firmware. but still same problem. I could not see any thing related to the support of this drive on my motherboard. 

i have read that the speed of harddisk can be reduced to 3GB/s by putting jumper in pin no. 5-6, but that did not solve the problem. 

I have also heard that speed of drive can be reduced by using wdspeed tool. I could not find that tool and how to use that tool.


We are on the same ship I guess…

My Caviar Green WD10EARS is doing this too. Western Digital is truly screwing something up. I hope that if you get a solution it works for my drive too.

Update: Try pressing on several places on the PCB. Not too hard! It fixed it (temporarily?) for me. For more info check  here.