My New MyPassport failed me. Please help!

Dear all,
I purchased my 5TB My passport a couple of weeks back. First thing i did was to format it to Mac OS Extended, after which i i backed up my old MacBook and migrated into my new MacBook Pro. Everything was seamless.
I connected it yesterday to back up and store some files, and was surprised that it’s not appearing, When i connect it, the tiny bulb lights up and i can hear/feel the disc spinning inside, however it’s not there - not getting recognized - not even in Disk Utility.
I tried two different cables, i tried restarting, i tried on other Macs and PCs with no success.
It’s very frustrating, no access to any of my data and not really sure if i lost them permanently.
Any advice on what to do please??

have you tried reinstalling it from your PC’s device manager?

I do not know what that means.
But when I tried it on a PC, the device manager said “unrecognized” and it did not appear in the windows explorer


Then have you tried using third party recovery softwares? what did you use?

I did not. What do you recommend?


I don’t know if you have tried this method, if not, please do this and update me what happens.

  1. Go to Device Manager, and under Disk Drives, you must see your External Hard Disk Drive’s name.

  2. Right click, and Update the driver.

  3. After that, if there is no changes to your problem, go back to the Device Manager > Disk Drives. Right click and Disable your device. After few minutes, enable it again. See if there are changes.

  4. If none of those above worked, uninstall your drive. Unplug it from your computer, and plug it again. It should reinstall itself.

Update me! :slight_smile:

First, I really wanna thank you for all the help you’re providing.
Please note that when I plug in my Hd (although you lights up and spins) it does not appear under disk drives in the device manager like the other hard disks or usbs.
This is why I can’t perform driver updates nor uninstall/reinstall because it’s not there.
On PC it stopped appearing in device manager and on Mac it stopped appearing in disk utilities.


Alright, then try this.

Before you turn on your computer, plug in your drive. Then right after the Windows starts up, go to BIOS. Press Del or F2 depending on your device. Go to BOOT, and check if your drive shows up.

If not, try all the USB ports you have, and all the connector wires your can use.

If none of these works, your drive might be corrupted and you might need to send it for Data Recovery.

Again, thank you Jedirene for all the help and support.
I followed your recommendation and it did not show in boot as well.
Now how/where to do data recovery?


Sorry, I think your drive is faulty then.

There can be various reasons for a storage drive to become unresponsive. Reconnecting the drive won’t help in most of the cases. In that case, recovering data from the faulty drive is the best option. If you don’t have any backup & you want to recover data from the drive then here, I suggest you to check out the below link to know the possible solution for the same:

Hope this will help.