My Net N900C HDD and attached USB drive cannot be accessed by Windows 10 laptop


#1

Hi,

Have had a MyNet N900C router for years with little problem.

Internet and WiFi both working fine.

HDD and USB attached storage accessible from Windows XP computer (yes, I know, don’t judge) and from Windows Vista laptop.

Have now bought a lovely new Windows 10 laptop to replace both of the above obsolete machines, but have been forced for the past 2 months to continue using them because I cannot access the HDD or the USB attached drive on the WD router.

What am I doing wrong? I’ve downloaded and installed the latest firmware, in case that was the issue, but no luck.

If I use file explorer to navigate to N900C, clicking on it just brings up an explorer window to login to the admin page of the router. Logging in doesn’t make any difference.

Thanks in advance. Hoping it’s something obvious - but I can’t work it out.

Kind regards


#2

Hi xadoc,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support

The link below will allow you to call support.


#3

Thanks, Brandon. Will do.


#4

Have submitted a support ticket, but doing so linked me to a number of other support ticket answers. Hoping this one is my saviour. Saving it here so I can find it again, and in case anyone else needs it!!

edit tried it. rebooted. no change. drat


#5

THIS WORKED!!!

(sorry for shouting, but I’ve been trying to fix this problem on and off for soooo long…)

Right clicking on the ‘storage’ and selecting ‘open’ worked. Perhaps because I’d done the previous step to enable CIFS support, because I could have sworn that I’d tried this already… But never mind! It works at last!