My Net N900 - failing

Hi all, i bought a my net n900  router, everything was great until this weekend.

i started having real slow transfer using utorrent.

then, suddenly , wifi stoppd working.

i tried to access the web gui , no answer .  the router disappear from WD quik view.

rebooted the router, back online for a few minutes. 

then again, same issue.

did a firmware upgrade to version 1.07.16 , same issue.

i got only enabled 2.4 ghz wify, the rest is disabled.

the weird thing is, when the router hangs, ping from my laptop to the router works .

but internet, and gui admin is dead.

i was thinking a temperature problem might be the issue, cause i dont see the cooler run.

any clue on what can i do besides replace the router?

the bad thing is , i bought the router and brought we me to argentina, i CANT replace the device, im very frustarted.

 i got one wd live hub, two wd tv live , one mybook live of 3tb, three elements of 1tb. all of those works perfect, the router is the issue , very disapointed, i will have to get my linksys wrt54g back and have lame bandwith.

Why can’t you replace it? Last time I check WD does worlwide replacements, and it sounds to me like it should be replaced if the problem is heat.

you might be right, i can send the device via mail , if i cant find any solution .

matongax wrote:

you might be right, i can send the device via mail , if i cant find any solution .



I’ve seen posts about the routes heating because of the fans not working, but opening the router case to replace/repair the fan would void the warranty, so there’s not much to do other than confirming if you get the problem if the router is tested in a place with really high ventilation from bottom to top, as the fan would work.

matongax, does ping using only IP adress (not domain names) work outside the LAN?

you can try pinging a google dns server (

ping works in the lan, when then router hangs, all internet traffic goes down, dont work , same with WEB GUI.

i was hoping that some technitian, came with a script or something just to test parts of the router. some bash scriptings or something , i dont know, im just guessing. im still not sure if the issue is being caused by cooling, and if the heat overheated something that now is broken.

matongax wrote:

i was hoping that some technitian, came with a script or something just to test parts of the router. some bash scriptings or something , i dont know, im just guessing. im still not sure if the issue is being caused by cooling, and if the heat overheated something that now is broken.

WD has not made such script, so a user script would have to void the warranty because it would be unsigned code, likely on SSH.

It’s still not clear to me if you have tried to ping an outside IP or just an outside domain name (or if you try to acces the Web GUI using the router’s IP or just the  “wdrouter” alias).

You might want to read this postand maybe try to disable DNS Proxy if symptoms are similar.

i did tried, ping -t , and works until the router hangs, then only local pings keep working, but internet conections and web interface stop working

if i just unplug the router and turn it bakc on , router works fine for 10 -30 minutes top

here is what i was able to test so far.

  1. Did a rollback to the 1.05.12 , using .Rollback_My_Net_N900_1.05.12 file.

  2. did a factory reset.

  3. configured my wifi , in 2.4ghz but leaving everything as it is except the password.

  4. configured my pppoe connection (dsl 512kbps , should be pice of cake to handle on this router).

  5. plugged a mybooklive on one ethernet port.

  6. plugged a wd tv live hub on another ethernet.

  7. connected a wd tv live  using wifi, and several smartphones and laptops.


  • Seems to be that everithing in LAN works, even Internet Link.

  • Wifi , here is the main issue, most of the devices looses their connection , in windows 7 , i get the “limited access” ,    i’m unable to ping the router.

  • on some devices, disconecting and conecting, does the trick , but not all the time

  • after a night running, wifi got completelly down , no even disconecting and re connecting gave me connectivity.

  • another thing i found, on both  firmware version, i’m trying to register the device, and i cant, using the web interface,

i think the router is deffective.

I have the same issue. Wireless appears to stop working while the signal still appears to be broadcasting but i cannot ping the router by IP address, connet to the web interface or get name resolution by pinging I tries a wired connection today before power cycling the device and the wired connection working just fine. 

You may want to try the wired connection to verify that all is well and that it is just the 2.4 GHz wireless that i causing an issue. Since i am still under warranty, I have opened a support request to see if there is anything that they can help with.

Hi louis! Yes same issue, finally we had some calls with wd support , and we ended up confirming that is hardware malfunction,
I got a rma allowance and now im waiting for my new router!

Didnt say anytihng yet because i want to test the new one.
So far im 99% satisfied with WD SUPPORT!

My solution to the problem is to hang the router using the Ethernet cables connecting to the Ethernet ports and keep the router no more than 2 feet above the floor. Since the fan appears not functioning the way it is designed.  This is a passive heat management that allow the heat travels up and through the gaps between the components. When the router lays flat, the heat will heat up the PC board and components mounted on it.  You also can hang it on the wall with a piece of narrow wood strip goes between the router and the wall. The ventilation holes must be on topside.  I have not have wireless or internet problems for more than 2 months since I have done this in late August. 

Hi All, i got a RMA replacement for the router, and everything was working perfect  until day 2. SAME ISSUE.

Wifi seems to be hang , the weird thing is, i got two other routers a linksys wrt54g and a dlink 600, and when i use the others, (just replace mynet with the other)  , wifi works just fine.

i dont understand what could be wrong, two routers same issue ? can i get that bad luck ? 

I Tried to separate the router from where it was placed, likce 4 cm from th surface, same issue. any clue ?

PS: WD support is amazing, they shipped a new router to my country,  gREAT WORK!

here is what im trying now.

1.did a factory reset

  1. enabled wifi at channel 11

  2. i left my old liknsys router providing wifi to my home, and plugged the mynet  to lynksis.

  3. set internet connection via static ip , to go out thru the lynksis.

  4. set dmz to mynet ip address on the linksys the one with internet.

so far, working , 30’ , torrent speed, **bleep** totally 0.1 kbps

hi all, today router wifi was not working, my win7 was saying limited access.

my iphone was conneccted but not working.

only two wifi devices conected to the router .

i think this new one is also defective. amazing

same issue here…

usually 5g fails first

have you got any update ? any tip or something?

the new router from RMA, came with latest firmware.

Hi all, new update, got contacted by WD support.

this is what we tried. 

i’ve changed the router to AP mode,  using WAN connected to my old Lynksys wrt54g.

Same issue.

Wifi works fine,  at night i leave Utorrent running , and at the other day, i get, Limited Signal  on my laptop, my iphone is connected to internet but is not browsing.

WD QuickView software doesnt see mynet router.

BUT, if i just disconect my wifi and connect back in, works. 

so , for some reason is like my session gets hang.

am i the only one whos facing this issue ? , this is the 2nd mynet 900 router but the issue is kinda similar.