My Net N900 - Drops External Connection

The My Net 900 device that I have seems to like to drop the external internet connection and has been doing so on a daily basis. Powercycling the device seems to fix it for about 5-30 minutes before it reoccurs. If I let it sit without power for ~10 minutes its good for another 1-2 days before this problem reoccurs. 

When it drops the external connection the first time, I can still get to the admin interface but it will not successfully connect to the internet until I powercycle the device. I have been running firmware version 1.07.16, and have reset it to defaults multiple times. Tonight I rolled it back to 1.05.12 and will monitor if this increases the stability.

I was quite impressed with the features that this router offered, but #1 priority in a router is stability. If it cannot stay online for more than a day or two at a time, then it is more trouble than it is worth.


Do you encounter the same issue if you disable the Fastrack QoS service?

I have not tried disabling the FasTrack QoS service as I attempted to use the “Connection Check” function on the router itself and it did not go through during this timeframe for a site that works when I am not experiancing this issue.

Weatherlight, read this please, might be related.

1 Like

I rolled back to version 1.05.12, so I made the change by disabling the “DNS relay”. If it is stable I will try upgrading the firmware again. Thank you!

Is it working ok now? (as in stable)

If you haven’t had any problem lately you should consider upgrading back to the latest firmware, as 1.05 is a security risk (at least with Plug n Play and Remote Administration left on).

I have noticed the same issue with my router. I just found this post and disabled the QoS. My router was also dropping the WAN connection about once daily. I will report back if this occurs again in the next couple of days.

I have had identical issues.  My cable modem was to blame.  Despite the modem operating perfectly, wd did not like the old modem.  It was docsis 1 for reference.   I suggest a modem swap.  See this post…

Modem issues

I’ve had my router running without QoS since my last post, and I have not experienced the WAN dropping. I can say that my modem is 7 years old (from the cable company) but I haven’t had any issues since I disabled QoS. It wasn’t a big deal for me because I was just being greedy on my home network for my computer, but it isn’t a dire need. Of course, I don’t like the idea of having to turn off some functionality so if there is some way to resolve that and not bring back the WAN problem, then I’m all ears.

I took Nissan’s advice and took my modem back to get a newer model (as stated, it was the original one I got with my initial subscription 7 years ago.)… I have re-enabled the QoS and have yet to experience any connection drops. Thanks for the advice!

All WD router owners should take notice of this!  I publicly bashed WD for months regarding their complete failure of a product.  My problems were 100% resolved with a modem replacement.  IF YOUR MODEM IS OLDER THAN 2 YEARS, REPLACE IT!  The problem is around the DOCSIS levels.  WD probably wrote all code in router to take full advantage of latest technology, not taking into consideration older technologies.  This is a problem for sure.  My old school V1.0 modem had so many faults/errors in its internal log it was not funny.  Due to the cable networks constantly changing, my hardware was left in the dust.  Due to this, My N900 was a complete brick, while my old school routers worked flawlessly.


The router was stable for around 2 weeks before I tried upgrading the firmware back to 1.07. It failed within 30 minutes of the upgrade and failed again. I rolled it back to 1.05 again and it started working fine. I have only had to reset it once since I rolled it back this last time (~3 weeks running time), and I belive that was an issue due to a neighbors router squating on the same wireless channel.

I currently have QOS disabled, because I have not had the time to reconfigure all of the rules but was working before the last firmware cycle. The DNS relay option is also still disabled, seems to have improved stability but I have not been able to test this fully.

Hold on a sec while I invest another ~$100 in a new DOCSIS 3.0 cable modem… I am glad that you replaced your **bleep** modem, but if the WD N900 does not work with common equipment required (provided) by your cable provider I have an issue. This should be well documented and available prior to purchase.

I personally own all my own equipment and had just bought a new Motorola Surfboard SB5101 which supports DOCSIS 2.0 within the past year.  I did this because the modem provided by Timewarner was a 8+ year **bleep** that they then wanted to charge me for every month. This is the standard device provided for new installs, so unless WD is willing to document their devices inability or problems working with DOCSIS 1.0 and DOCSIS 2.0 modems it is their fault.

Edit: I personally think that  inserting  “**bleep**” is more offensive than the acronym that I used.  Hint it is simmilar to “Piece of Garbage” but hey WD that’s your call.

1 Like

Since you are hostile and simply want to lash about a possible solution, I will reserve my comments…

I had an ancient docsis v1.0 modem.  I had the same problems as all.  Simply calling my isp and getting something modern resolved my problem.  I have no problems after a simple modem swap with all n900 features enabled.  It has never operated this smooth since day one.  I can honestly state that my modem was the problem.  I do not work for wd or timewarner and I am not a mod.  What I can tell you is my problems are gone.  My suggestion has also resolved other member’s documented problems shown in post here on this website.  If you simply choose to ignore the advice of others,  this is fine.  But your stupid, non beneficial post is simply that…non beneficial.   This forum exist to help others, seeing how you have only posted 10 times, have you posted to help solve the problems?  I can sleep at night knowing my post are factual and contain solutions to other’s problems.  If you choose to ignore them, then ignore them, but do not publically trash me due to you knowing all the answers and not willing to try a different approach.  By trying my suggestion this would place blame with your own equipment, not wd.  I have publically apologized to wd due to acting just like you, blaming others when my hardware was to blame.  I am posting this show you that my “out of the box thinking” resolved my problems, not to try and act like you.  You should know that when you purchased your own modem, you took the responsibility of the hardware working correctly and knew it would break or become obsolete some day.  What I am stating is the hardware has evolved and so has the technology behind it.  If WD designed a router to be optimizied for 20 year old modems they would be out of business with a thought process like that.  Your argument is invalid due to you probably having bleeding edge cell phone technology, costing much more than a new modem to replace your 5 year old modem.

The problem with the WD My Net devices is that they lack documentation. If the device requires (or works best with) DOCSIS 3.0 then there should be some kind of statement from WD on this matter.

I have been very diligent in my testing and have considered that it was the cable modem, however I have not had a chance to install yet another modem as it requires another modem and an hour long phone call to TWC.

My modem (a Motorola Surfboard SB5101) was bought new this past January and was a large upgrade from the past modem as the new one supported DOCSIS 2.0. In January there was only one modem that was DOCSIS 3.0 compliant and on the approved list from TWC. It had an integrated wireless access point and exceeded $150. Generally those AIO devices do not last very long under heavy use and was a waste of money as I bought the WD router for wireless access, QoS and storeage sharing features.

I was planning on upgrading to a Motorola SURFboard SB6141 when I upgraded my TWC service, but that was put on hold while I figure out if I need to replace this WD router.

I followed your link on the initial post and read it. There was also the next comment stating that this also worked for another person. The problem arose out of your second post, if you are going to copy and paste directions stick to the point and not a bunch of rubbish about how you saw the light. ELIMINATING THE USE OF ALL CAPS ALSO HELPS. USING ALL CAPS INFERS THAT PEOPLE ARE TO STUPID TO UNDERSTAND YOUR ENTIRE POST.

I have been a volunteer poster and admin on my share of forums and really do not have interest in adding another one, but I call it like I see it. You sir are artificially boosting your post count with your poorly written copy paste job and quick generalized answers. If one post that infers criticism sets you off about how you are able to sleep at night you may want to go talk to someone.

Thank you for Hijacking my thread.

This thread is locked to prevent any further antagonism between users.


Oh, and I did escalate this modem compatibilty issue.

1 Like