My Net N750 and Brother DCP-7030 printer


I am trying to use a Brother DCP-7030 with the N750 USB port and it doesn’t  show up in the WD Print Share Control Center.

In Print SHare, the server field has the router name and the ip address, but the “Device” and “Status” fields are blank. I tried clicking on the “connect” button,

The router has firmware 1.01.20, and I re-installed the Brother drivers. The printer prints ok when connected to the computer’s USB.

Has this printer worked for anyone else and am I missing anything, or is this printer not supported.



Check this list for the printers that have been tested

1 Like

Thanks for that link.

I did some Googling and I wasn’t able to find out if that chipset for the Brother product listed in that link is the same as the printer I have.

I called Brother “technical” support and the person I was speaking to was confused that I was trying to plug in a USB into a network router. I explained that my question was about chipsets, and who could I talk to about that, but they were hung up on the fact that “This printer does not have a network card and therefore I doubt you can plug it into the network router”.

I gave up trying to explain for the 3rd time what I was asking. And that this router apecifically can function as a USB printing server.

So, I guess at this point the Brother DCP-7030 is not compatible with the MyNet N750.

I did confirm that the USB ports are working by using my WD Passport as an attached drive.