My Mac's can no longer mount the WD MyBook II World Edition 4TB NAS


#1

Everything was working fine - last night!

However, today for some reason all 3 of my Mac’s will no longer MOUNT the WDMB. They all show it in the SHARE area but the beach ball just spins for about 10 minutes and won’t connect. Everything worked flawlessly yesterday.  (Using Mac OS X 10.6.2 on a MacBookPro Core2Duo 

I have no problem seeing and mounting the drive from Windows 7

What’s up?

Edward

[text deleted for privacy] 


#2

I can mount it using SMB — but that is not what I want. 

My WD NAS is hosting my iTunes and my iPhoto libraries and when you connect via SMB those file look like UNIX files and the Mac Programs don’t recognize them.

I not sure what to do - 

  1. I did a RESET, which assigned a new IP, but that made no difference. 

  2. It’s strange - they still show up in Under SHARED in the Mac OS X side panel with other Network drives - but it just won’t Connect to the WD from a MAC.  It of course works fine under Windows 7


#3

Unfortunate Outcome: Mac’s won’t mount after (1st few days) the WD MyBook II World Edition 4TB NAS

Well - I did not receive any responses via the forum, I realize these take some time, so I called Western Digital Support Directly today and though they had to accellerate me to 3 different support levels over 60minutes - they were very helpful.

The Senior Technician in Calif. stated that the WD MyBook II has a problem with APPLE AIRPORT EXTREME wireless basestations (router).

Still seems weird that Everything worked flawlessly for 3 days - but then after that, NO Mac would mount the drive, the only way was to connect via smb:\ IP which is not what you want to see as you loose all of your ‘mac’ like look and feel and every file now looks like a unix file (like MS word doc without the .doc)

Unfortunately - the Sr. Tech stated that they have nor will be working on a solution for this - which is a Sad statement as the drive showed great potential at first, I had been surprised that it was so cross-platform compatible initially.

Luckily - I purchased it from BUYDIG and they have a wonderful return policy - so I’m sending it back!  I think I’ll just bit the bullet and go with the more expensive QNAP product. Sometimes saving money and buying the ‘deal’ is just not the ticket.

Oh well - best wishes to everyone, but being a dual platform user (Mac and Win) I need a NAS solution that’s solid.

Thanks to Western Digital - you’re about 90% there but you really need to go the next step as if this had worked you would have had a Great Home Media Server Solution.

See you in the QNAP forums…


#4

Well the error seems to be with WD. The unit I purchased is:

WD My Book II World Edition 4TB NAS - and it states clearly on the Page that its compatible with both Mac and PC

http://www.wdc.com/en/products/index.asp?cat=14

http://www.westerndigital.com/en/products/Products.asp?DriveID=589

These devices are listed under the NETWORK storage TAB (not the Mac Products Tab) and the one I purchased clearly states that it even supports Apples TimeMachine backup software and is also Windows 7 compatible.

Sorry Charlie - but it seems Western Digital needs to correct this error - and then inform their own Tech support personnel, as Tech Support is stating that its a known problem, however the website states clearly that both Mac and Win 7 are supported.

Ed


#5

Just got me a 2TB WD MyBook II WE - and that ■■■■■■ is playing these tricks on me.

I can access it from a Windows 7 machine. My Mac can see it, but not use the shares. My PS3 and my KiSS media player can use it as a media player.

This is just to let WD know that I am absolutely furiously pissed over this. I copied ALL of my data on there, and now I can only access it from my wife’s pc ?

WD needs to get this fixed ASAP ! This is listed as Mac compatible. So I expect that it is.

GO… FIX !!!


#6

Bumped.

What’s happening WD ? No answer here, no answer to my support ticket.


#7

JacobSaaby,

Your case has been escalated.  Someone will get back to you, shortly.


#8

Dear All,

Same Problem here! It worked fine the last 6 days. Yesterday it was great, this morning none of my (2) macs mounts. While the PC with XP works fine.

I’m afraid I have to take this thing back to the store. Not happy… at all.

Took me forever to copy all of my data to the WDMWE

Thanx,

Tim


#9

Well since I’m the one that started this post - I thought I’d give you an update.

I have returned my WD MyBook II 4TB NAS, purchased at BuyDig.com, though I’m still awaiting them to refund my credit card (its been over a week - they did state its in processing).

SLOW

What I initially wanted to do was to Move my iTunes library to the WD MyBook NAS and run it from there - as stated it worked for a few days - but then really got messed up. AND IT WAS EXTREMELY SLOW. Now that could be my Network, but I have gigabyte ethernet so I know it was not.

OTHER NAS DEVICES

After more research and speaking to several other’s who have NAS devices - the one critical thing they all state is to make sure that whatever NAS you choose - be sure that it supports the AFP (it will support others but  - as they all felt that at least these companies are trying to ensure Mac compatibility and address the concerns of the Mac Community by adding this protocol so its a good sign)

These units also have Faster more Powerful Processors in them - as they were initially designed for Office use.

Most everyone suggested either:

  1. Synology or

  2. QNAP

Both of these NAS devices come with the housing however you need to purchase the SATA drives separately. They will likely come out costing about $500 - $700 depending on your configuration as you can get 2TB SATA drives for about $150 each and their empty NAS units are $300+

IF YOU HAVE AN ALL WINDOWS ENVIRONMENT - ALL THE NAS DEVICES WILL WORK FINE ---- HOWEVER, IF YOU HAVE A MAC IN YOUR ENVIRONMENT - BE WARE.

I’m 50 - 50 but for all my digital content I have made the decision to go with MAC and Apple (iTunes, AppleTV, iLIFE etc.) so this is a possible solution for those who just want to get something up and running without much hassle with 1 primary provider - that being Apple and does not mind using Mac’s for the Majority of the configuration process - however once configured all Media  is accessible easily via Windows XP and Windows 7. (I would never suggest anyone use VISTA  - get off of it asap - even Microsoft wants that dead).

MY SOLUTION

#1 My main concern when seeking a NAS device was backup/failsafe or RAID 1 (Mirroring) to ensure that if a drive failed I had all my digital media (movies, itunes and family memories stored in two places.

#2 All the other cool stuff a NAS device offer’s was and is cool - but honestly its stuff that I would call ‘geeky cool stuff that I would tinker with’ on a weekend, but really didn’t need.  Sometimes you miss the point - find out what you want - if its security and data mirroring - scale back and don’t go for a NAS as you will just end up playing with all the other stuff and overlooking what you really need. NAS’ are good - but there are some other alternatives.

MY HOMEMEDIA SETUP

 - 2 MAC’s running the latest OS (One Headless Mac Mini, One MacBookPro Laptop)

 - 1 PC running Windows XP

 - 1 PC running Windows 7

APPLE TV (2)

After testing and playing with Netflicks and Blockbuster through my BluRay player and Installing Boxee and playing with Hulu - it was all just too much. I wanted ONE SINGLE COMPREHENSIVE home media solution that offered 80% of everything I wanted, rather than a mix-up a cool free stuff. So I went with Apple and iTunes and Apple TV. Apple has deals with all the Major Media Studios so you get all the movies - you can rent or buy or preview trailers and the interface is beautiful - as expected from Apple. Apple Store is easy to use for everyone in the family. Yes AppleTV has its limits but I have all my content served up to 2 HDTV’s and any computer in the House that can run Windows or Mac iTunes - iTunes now has HOMESHARE built-in.  AppleTV is stupid in that its internal HD is only 160GB - my music library is 180GB - so that is just stupid. And Yes they do cost $229 per unit so its a bit pricey -but now I don’t think about it as it all works so well.

APPLETV after market add-on - “ATVFLASH”  $49.00

Check out a very cool tool  "aTVFLASH’ which is an AppleTV hack that is really easy to install and is all software based and can be completely reversed so it does not effect your warranty.

This software will let you hook up to Youtube, and Radio, it includes a WebBrower and Keyboard software - supports waayyyy more video codecs than Apple allows you upload and download via FTP from your appletv - so all the things that Apple should have put in AppleTV to make it an OPEN media center - ATVFLASH does - including allowing you to run FIREFOX browser and see Flash movies. Sapphire and Boxee and all the free stuff you can find - it rolls it all in to one simple install.

I have 2 AppleTV’s connected to my 2 HDTV and both are set to STREAM content from the same Mac Mini Media Server.  Since I have set them to STREAM, I needed to find a way to get content that I purchased from the Apple Store directly through the AppleTV. As the only way to do that would be the SYNC the unit - but that is a whole other weird scenario apple should re-think - but ATVFLASH lets me ftp into the unit and retrieve my purchase content so I can add it  manually to my iTunes library. This would be a nice wish list item for ATVFLASH to add an automated way which included other computers like my Mac Mini-- however, they do have the ability to via ATVFLASH to use an external USB device as your iTunes library (like the Thermaltake below) so you can’t complain too much. I would like them to allow you to select a Network Share as well.

HARDWARE

I have a Mac MINI as my Media Server - the drive was too small so I got an after market replacement 500GB. It is headless (no monitor) saves money, as I just Remote in using Apples Built in Screen Sharing - or you can use a free opensource application called CHICKEN OF THE VNC which lets me take over that mac as if I was working directly on it.

POOR MANS NAS in lieu of WD’s MyBook Scenario

Found  two really cool CHEAP alternatives that addressed my main concern.

  1. THERMALTAKE

http://www.thermaltakeusa.com/Product.aspx?S=1268&ID=1895

$49.00 at TigerDirect.com

http://www.tigerdirect.com/applications/searchtools/item-details.asp?EdpNo=5352947&SRCCODE=PRICEGRABBER&cm_mmc_o=2mHCjCVybgwTyz__wyCjCVqHCjCdwwp&cpncode=23-80375567-2

See it to believe it - it has USB or eSTATA connectivity and has one or two drive configurations and accepts 2.5 or 3.5 SATA drives (whatever size you choose). It see’s the drives as 2 separate drives and is connected directly to my Mac Mini - and fortunately Apple has RAID 1 functionality built-in to their disk utility so I formatted the drives in Raid 1 and now when I backup to the first drive - it automatically writes to both!

POGOPLUG $129

Next step:  This one I have completed my testing - but I’m hopeful

PogpPlug by CloudEngines, a weird little device (hope you like hot pink) with a very colorful stand. Its really a NETWORK device for USB hard drives. It puts them on your Home Network as Network Shares!  And it even has an option whereby you can Access these Shares over the Web from anywhere in the world. 

Now if it works and see’s my ThermalTAKE (RAID1 configured) drives - then I have a Poor Man’s NAS and it solves my over problem. I’ve read that some people have had success connecting pogoplug to the 1 slot thermaltake, but not the 2 slot - so I’m hopeful I can get it working especially since I would be using the Raid config i stated above and It may just see it as a single drive which would be fine.

So for a total of $336.00 ( $49 thermaltake dual + $129 pogo plug + $79 each for two 1.TB SATA drives) I’ve solved my problems.

And strange enough the part I’ve tested so far is that the PogoPlug networked Thermaltake device is faster on my Network than the WD MyBook - so far!

And everything I’ve stated above works for my Mac’s and PC’s - though of course the RAID1 scenario is dependent upon Apples Disk Utility to Format the drives. It also allowed me to Partition the Drives so I have a big chunk for MAC and a Windows Partition - FAT, which I then accessed and mounted on Windows 7 whereby you can Change it NTFS if you wish.   


#10

Then!!! any solution? I’m still waiting for a solution!!


#11

Friends,

I did a factory reset. Everything works fine again. A factory reset erases the disk.

Of course I had to copy 750 gb of data to a backup disk first… And now I have to copy it back.

However, that is not what I’m going to do. Because I don’t trust the thing anymore. For all I know am I going to be confronted with the same problem in a few days. I’m going to take it back to the store today.

I send a support question to WD… I takes them forever to answer. Bye Bye WD.

Thimmo 


#12

I was originally having similar symptoms to other users.  My MyBookWorld would show in the Shared pane, but not be mounted and the Anywhere software would tasks files for backup but not be able to back up the files.  The Anywhere software was “Disconnected” from the MyBookWorld.

I found that I had to manually click on the MyBookWorld name in the Shared panel to actually mount the drive (as evidenced by the up arrow next to the name).  Once the drive was mounted the Anywhere software backed up my data.

I then remembered about startup at login (found in the Accounts pref pane/login items for each user).  I selected the various MyBookWorld volumes to mount on login and my setup is working flawlessly.

I don’t remember seeing any documentation for Mac OS X users regarding mounting the drives at login.  I think that if that tiny bit of information was more clearly documented it would save users a lot of heartache.

Mac OS X

MacBook Pro

iMac


#13

Be Careful - I did all the same things and it was all working flawlessly as well.   Until it stopped …


#14

Found a fix. I’ve posted it here:

http://community.wdc.com/t5/My-Book-World-Edition/Cannot-AFP-to-1TB-MBWE-SMB-works/m-p/32180/highlight/false#M1470