My Latest "Safely Remove" Strategy

I previously could use the WD System Tray Icon “Safely Remove” AFTER I DIS-abled the Continuous BkUp Smartware App - AND - Rt Clk MBAM Tray Icon = QUIT… Either Win Updates or an App Upgrade have now made it Impossible to Safely Remove either a 4-Yr old My Passport or 2-Yr old My PPt ULTRA - UNTIL I do the following from an old post I Googled …
I Now Disable Smartware, Quit MBAM, Pause ESET Security Protection, AND do [ RUN: services,msc ] and Find WD Drive manager and WD Backup (engine). Rt Clk’ing the Drive Manager = STOP also Stopped WD Backup, which I’d want.
The WD Tray Icon Disappears BUT I NOW can use the MS Safely Remove and the Safe to Remove popup appears.
I started Disabling ESET because every time I tried the WD Icon Safely Remove I got NEW ESET popups about “J: Drive (or E: drive) is now Recognized” that were never there prior. Thought ESET may be part of the Close All Apps and Try Later popup we all hate.
I PRESUME the WD Tray Icon can’t Reappear unless I Re-Start the computer.
Safely Remove is a universal nuisance for so many that maybe this approach will work for those who’ve tried everything else. The prior post-er stated this [ services.msc STOP ] trick became intermittent, but I’m tired of Turning OFF the computer to Change-out Drives, so we’ll see.

Hi CraigS26,

I really appreciate your time for providing your troubleshooting steps regarding safely removing the drive, I hope this will help other users who all are facing same issue.

Also, you can safely remove the drive using WD Drive Utilities.

Please refer to the link given below in order to know how to safely remove the drive using WD Drive Utilities.

EDIT 11/20/17: In the Greatest Tradition of Safely Remove ALL methods to use it Failed several weeks ago. Some Apps update occurred in the interim and All of a Sudden the following now works: Quit MBAM, Run: services.msc/ STOP WD Drive Mgr which STOPS WD Backup. Using MS safely Remove Sys Tray Icon is CURRENTLY Working. Actually, Start WD Backup Starts the WD Drive Mgr after Drive removal Vs the opposite to STOP.

Thanks, Alex. As with the post-er I got the idea from, turning Off varied Apps + WD Drive Mgr & BkUp in [ services.msc ] stopped allowing Safely Remove to work as it first did.
From my ESET Security App Forum Sppt I was advised to try — in Advanced Setup for ESET EIS/ Anti-Virus/ Removable Media … I turned That Module Completely Off and turned the computer Off / Back On.

Since doing THAT - the MS Safely Remove button works every time without me having to deal with Other Apps at all.

I first set Removable Media to Do Not Scan (vs. Auto-Scan) with the module “on” and Safely Removed failed again. I’m not sure if I had turned the Computer OFF/back On (or Re-Started) would have solved the issue - OR - whether the Module being Completely OFF is required + computer Off/On or Re-Start.
I hope I don’t have to Edit this again because of a change in success rate. FYI .