My home Internet is slowing down

first reading should be ping not pimp. LOL sorry:smileyvery-happy:

Can you access your mycloud?

You could try another Ethernet cable between your router and mycloud.

You could also see what happens if you change to a different port on your router.

I’ve actually been noticing this too lately. I have a 4TB MyCloud.

I’m still doing some testing, but it seems every time I connect the drive to the router speeds start dropping until they reach about 1d /1u.

A simple reset on the modem and router at this point wasn’t doing anything, but while trying to diagnose I unplugged everything and it was stable for two days. At which point I reconnected the MyCloud and within a couple hours the speeds dropped back to 1d/1u. I’m not doing any transfers to or from the drive during this point in time, it just seems to drop off.

I recalled that when I first set it up I didn’t use the cloud feature to allow me to access the drive outside of my network and that around the time that I activated that feature is about the same time that the problem started to happen.

I’m currently testing to see if there is anymore to this idea. So last night I disconnected the drive, rebooted my modem and router, checked that the speeds were back up, then hooked the drive backup, went to the settings and disabled the cloud service.

I’ll check the speeds when I get home today and for the next couple days to see if things still slow down or not.

This actually makes me wonder about something I thought about when I was purchasing the MyCloud drive, which was why I needed a login setup through the WD website to access my drive. Like is this strictly some kind of proxy or vpn connection to get to my drive, or are my files or even some part of my files being uploaded to a server without my knowledge?

I’m having exaxtly the same problem – when my newly purchased WD My Cloud 4TB is plugged into my BT HomeHub router the internet speeds plummet. As soon as I unplug it the internet speed returns.

Any update on wthat’s causing it as I’m on the verge of returning it!

I don’t understand why plugging in a device whether it is the WD Cloud or otherwise can affect the speed of a router unless you are having IP clashes? or perhaps a clash between negotiating for 100Mbits and a gigabit speed.

So try the following experiment, pull all your devices off except your pc and wd Cloud to see what the network speeds are? If that is working at high speeds, then plug in one by one your other devices until you find a problem.

I do know that if you plug a 100Mb/s device into a gigabit router or switch, you will get a drastic reduction in speed.

@ Ralphael,

You said: “I do know that if you plug a 100Mb/s device into a gigabit router or switch, you will get a drastic reduction in speed.”

Not when you have a managed switch. Not all hardware is 1 Gbps. If you have a network printer on your switch, they usually are 10 Mbps or 100 Mbps. With a managed switch which has a processor in it, it should not be a problem.

Managed switches provide all the features of an unmanaged switch and provide the
ability to configure, manage, and monitor your LAN. And this gives you greater control over how
data travels over the network and who has access to it

Pacific_Dollars wrote:

@ Ralphael,

 

You said: “I do know that if you plug a 100Mb/s device into a gigabit router or switch, you will get a drastic reduction in speed.”

 

Not when you have a managed switch. Not all hardware is 1 Gbps. If you have a network printer on your switch, they usually are 10 Mbps or 100 Mbps. With a managed switch which has a processor in it, it should not be a problem.

 

Managed switches provide all the features of an unmanaged switch and provide the
ability to configure, manage, and monitor your LAN. And this gives you greater control over how
data travels over the network and who has access to it

 

Totally true if you have a managed switch, but not all routers are created equal nor do we have 10Mbps printers anymore; thus a router can take a shortcut and lower the network speed to the lowest common denominator.

Ralphael wrote:

So try the following experiment, pull all your devices off except your pc and wd Cloud to see what the network speeds are? If that is working at high speeds, then plug in one by one your other devices until you find a problem.

 Have done the above and can confirm it’s the WD MyCloud that is causing this problem – when it’s the only device connected (apart from my Mac) the internet slows down dramatically.

are you using the ethernet cable that came with the Cloud? at least a cat 5e?

That would probably be my last guess…

Yes I was using the cabe the came with the MyCloud.

I actually returned the product to store this afternoon and bought a different brand instead. Seems to be working much better than the WD.

I have notified an investigation team about this.

Regards,

I thought the same thing but now my download speed is back where it is suppose to be. I know right before I bought My Cloud Time Warner Cable had an outage in my area. After getting My Cloud and testing it my download was showing 10Mbps. My download is back to 16Mbps. See image below.

My upload has always been around 1Mbps.

WDMCRRtest.JPG


I just resolved a Windows 8 slow down/ page time out problem on my Netrgear router by changing the router max transfer speed from 300mps to 130mps on my 2.4g interface only (that is the recommended default). My 5g interface works fine at 300mps. I try and use the 5g interface for any large data transfers. My slow down problem occurred prior to me installing MyCloud but it can be aggravated by any heavy volume transfers. My windows 7 PC did not have slow down issues and it uses the 2.4g interface only. I don't know why win 7 ran and 8 did not, maybe 8 has a faster interface.

I have the same problem with a 4 TByte MyCloud, Netgear router and Windows 8.1.  Period slowdown in internet speed as measured by Ookla speed test.  My Kaspersky Internet Secuirty’s network monitor shows MyCloud is busy uploading data periodically that correlates exactly with the slow internet speed.  Don’t know where the upload is going to.

Very disappointing.  I may have to take the MyCloud off the network.

Has WD found a solution for this? I bought mine (WDMy Cloud - 3TB) two days ago and connected. The file transfer over LAN was very slow.

Now after two day, I see my Xfinity broadband speed almost at 50%. As soon as I disconnect the WDMyCloud from my network, the speeds were normal. I repeated this test several times, and got the same results. With WD My Cloud in the network, the nework speeds are drastically reduced. 

I am going to keep this PoJ for another day before I return it. Just want to give it a fair chance.

AJ

Everyone experiencing this issue hopefully my fix (or something similar) works for you.  Before you throw your My Cloud in the trash take another look at your router options and configuration. 

I was experiencing intermittent and dramatic internet slowdowns but my LAN speeds were normal.  I have Time Warner in TX with 50Mbps download and 5Mbps upload.  I had recently purchased a new Asus RT-N66U Gigabit Dual Band Wireless Router.  I had also recently purchased a new Motorola Modem - SB6121.  It took a lot of process of elimination but I finally managed to determine it was the router that needed a config change.  Download speeds connected directly to my modem were fine and consistent, signal and power levels on the Time Warner cable were fine.  I could plug my laptop back into my Asus router with no other devices connected (including the My Cloud) and see 50Mbps download speeds.  Then I start plugging other devices back into the router and at some point my internet download speeds would drop to 20Mbps or below 1Mbps.  My upload speeds never seemed to be affected.  Asus technical support pointed me in the right direction.  The Asus router has a feature called QoS (Quality of Service).  The manual listed it as an optional feature and didn’t go into detail on how or why it might be needed.  This was off by default from the factory so I had left it off.  I turned it on, entered my ISP download/upload speeds and did some more testing.  My slow internet download speeds never came back.  Apparently this is more like a “required feature” on the Asus RT-N66U.  Other routers may have a similar feature that should be enabled.

Keep in mind I did experience slow transfer speeds with My Cloud over the LAN but that was a separate issue from the internet slow downs.  After tuning my Wifi and testing over Gigabit Ethernet I found slow file transfers on My Cloud were mostly from the file scanning performed by two WD daemons running on My Cloud.  After disabling those my transfer speeds to/from My Cloud improved dramatically.

Good luck.

Thanks JDEVINEY!

This shoudl definitely help. Couple of quick questions:

  1. Did you create a specific QoS rule or just simply turned QoS on in the settings. Did you have to make any priority changes in the rules table provided? Below is a picture of what I’m talking about:

  1. How did you disable the daemons on WDMyCloud?

Thanks much.

SurfinAsh wrote:

Thanks JDEVINEY!

 

This shoudl definitely help. Couple of quick questions:

 

  1. Did you create a specific QoS rule or just simply turned QoS on in the settings. Did you have to make any priority changes in the rules table provided? Below is a picture of what I’m talking about:

 

 

  1. How did you disable the daemons on WDMyCloud?

 

Thanks much.

  1. No I did not create any specific QoS rules.  I used whatever Asus created for me by default and it seems to work fine for me.

2.  Here’s a link to another thead I started.  The last post is how to disable the scanning daemons.  I can’t take credit for the original workaround but I do mention it and link to it from my thread.

http://community.wd.com/t5/WD-My-Cloud/Slow-performance-and-file-scanning-applications-on-WD-My-Cloud/td-p/770261

The QoS definitely has solved the network speed issue. So many thanks for that.

I was blocked when I tried to SSH into the WDMyCloud. However, I found out that you could go into the Dashboard> Settings > Utilities and save the config file. Then edit the config file to enable SSH (there is a parameter). You can then reimport the saved config file. Seems to have worked…

Glad I posted the question before returning the product.

SurfinAsh wrote:

The QoS definitely has solved the network speed issue. So many thanks for that.

 

I was blocked when I tried to SSH into the WDMyCloud. However, I found out that you could go into the Dashboard> Settings > Utilities and save the config file. Then edit the config file to enable SSH (there is a parameter). You can then reimport the saved config file. Seems to have worked…

 

Glad I posted the question before returning the product.

You should be able to enable SSH directly in the Dashboard UI.