my home duo not working with big sur

since upgrading to Big Sur my home duo no longer appears as a drive, i downloaded the “discovery app” the app says that i have to “allow access” i have done that (to the best of my knowledge) and it doesn’t work.
i uninstalled the app, re installed it rebooted etc, nothing works, and, you can’t actually plug into the hard drive though the USB to access the drive (how stupid is that)

i can access my files through the web browser but, can not access the drive directly. i am working with large video files that take HOURS to move though the web when it took seconds before
it worked before as an available drive though my home network.

Hello,

Please refer to the following KBA article and follow the instructions to install WD Discovery on your Mac OS 11
https://support-en.wd.com/app/answers/detail/a_id/29822

I have done that multiple times, I installed that app, from that article and tried to run it, when attempting to sign in to the drive my computer asks me to allow access from the “general settings”
I have done that, it will not sign into the drive or acknowledge that the drive even exists.

I have run the “uninstaller” for that app, then re installed it, I have rebooted my computer multiple times before and after un installing and re installing that app. I have emptied my trash bin, and re booted my computer.

It does not work.
That is why I posted this question.

Is there something else that can be done? I have no practical access to that drive. I can sign in through “my cloud” through the Internet but the speed is so slow that it takes 12hours to upload