My Hard Drive no longer shows up in My Computer

I have a Western Digital 1TB Hard Drive (External). I use it 99.9% of the time on my Windows 7 64bit computer to store pictures/videos and backup important files.

It was working fine until I plugged it into a MACINTRASH to backup files from that computer. It was a simple copy and paste from the MACINTRASH to the External HDD.

After copying the files from the MACINTRASH, I plugged it back into my PC.

My PC no longer recognizes my external HDD. I unplugged the power, plugged it back in. Same with the USB cable. Rebooted. Then my computer wouldn’t reboot and windows did its automatic self repair. Nothing.

I unplugged EVERYTHING and left it that way for about 30 minutes. I plugged EVERYTHING back to my computer and turned it on.

Windows booted up fine. I plugged in the external HDD and windows had that little icon telling me it was installing drivers. I was excited to think that it finally would recognize my external HDD.

Of course, it didn’t work.

I took the hard drive out of the casing/box. I know this voids the warranty… but the warranty has already expired on this junk. I plugged it directly to my desktop’s eSATA. It shows up in Device Manager fine.

In Computer Management’s Disk Management, it tells me I have to initialize the disk before I can access it.


You probably corrupted the drive when you hooked it up to the Mac unless you had software so it was useable on both. Windows and Mac use different fromats. If this is a drive With Smartware the data will be hardware encrypted and useless hooked up to eSATA or another enclosure. It needs the board with the USB port to decrypt the data. Try putting the drive back in the original case. Get a Linux Live CD and boot from that then connect drive and see if you can access your data.


I can see what you’re saying… but if Mac uses different formats, then the Mac shouldn’t have been able to see all my files before I did the copying. The Mac was able to write on the disk fine when I created directories. And the Mac successfuly copied the files onto the Hard Drive. I don’t see how something that uses different formats can do all that.

The drive became useless even when it was inside the enclosure. So hooking it back up doesn’t sound like a fix to me. That is why I took it out of the box. I asked help at windows forums (thinking it was windows’ fault) and most of the replies blamed my motherboard or blamed WD’s box from their experiences. Since more than one computer didn’t even detect my hard drive anymore through the USB, I knew it wasn’t my motherboard. So I had no choice but to take the hard drive out of the enclosure.

Considering that now my computer can actually detect the hard drive, I believe that the USB is part of the problem.

Now I would just like to figure out why it became corrupted by a simple copying of files from a [Deleted] mac or if I just used up this hard drive’s life span.

What if you have never hooked it up to a different computer and all of a sudden your computer can’t regonzie or find the HD?


That’s a different problem. Start a new thread with your OS and model name of your drive. Post what you have already tried like moving USB cable.


Can anyone at least recommend a good partition recovery program that can recognize a hard drive that is “not initialized” - ive tried 3 different ones so far and none of them can even recognize that my broken hard drive is connected (yet device manager can…)

Due to MAC feedback from their forums, it’s not MAC’s fault. It’s a WD **bleep**-out. No surprise.