My experiences with WD Live Hub - Belkin N450 F9K1105V2 - Monoprice Wireless N Adapter


Just wanted to get my experiences down on paper as there were a few things that I went through that I hope others can get help from.

My original setup with the drive was with an older DLink DGL 4300, which was G standard. I used the monoprice adapter with it though. It worked, decent, but not good. I was hoping to move all my digital movies over to the drive and get them off my main PC, but it was impossible. I’m not sure why, but the connection kept on getting interrupted and saying the network could no longer be found. This was using windows explorer and teracopy. Both had that unable to access network error.

So I went out and bought the Belkin router. Installed it and it was slower than the wireless G router. The settings looked good, and tried restting, using different channels etc. Nothing worked. Called Belkin and talked to a lady from the middle east for about 40 min. She was only interested in getting the speed fast through my laptop (wireless) as opposed to getting the live hub working, which she had me using wireless G mode. When I mentioned the hub problem, she told me to reinstall the adapter and try again. /sigh

At this point I was about 5 min from taking the router back to wally world, when I changed one setting in the wireless options. Bandwidth > 20mhz was put to Bandwidth > 20/40mhz. Boom. Hub worked super fast after that one change.

Now when I copy data from my PC to the hub TeraCopy is saying I’m getting 6.0 MB/s. Which I think is great. Anyway, just wanted to share my experiences and I’ve also included a screenshot of my wireless settings for the router. Cheers.

6MB/s is a pretty good wireless transfer speed. About 60mb/s. You only get 10MB/s out of the 100mb/s direct wired ethernet connection.