My Essential 2 Terrabyte drive: My BIOS no longer recognizes three of my internal drives


I have used Mybook external drives before without any problem. I have two 1 terrabyte drives that use a USB2 port, and they have worked extremely well. I decided to get a 2 terrabyte drive to back up my larger system, and so I bought a My Book Essential 2 terrabyte USB3 drive, which claimed to be able to work on a USB2 port. I unhooked the two 1 terrabyte drives and connected the new 2 terrabyte drive and all worked fine except the drive seemed to be very slow when I tried viewing the PDF document; in fact, the reader and the file browser both hung for a time and were not responding to the system. So, I thought I’d see if it would go any faster if I used a different USB port (I had it plugged into an expansion card and I wanted to see if plugging it into the motherboard USB port would make a difference). So, I unplugged it and plugged it into a different USB port. I then opened the file browser to access the drive, and it didn’t apear. Instead, the file browser began clocking – I assumed it was “rediscovering” the drive on its new USB port. I then closed the file browser window and restarted the system as I thought perhaps it needed to be rebooted in order to see the drive on its new port. What happened next was very unexpected: The BIOS can no longer see the boot drive, the application drive, and one of the data drive (drives C, D and F have disappeared from the BIOS). It now only sees one of the data drives, E, and a smaller USB drive I have connected. The system boots just past the memory check, hangs for a time when it reaches the USB part of the boot, and then fails to start because it cannot see the boot drive.

Does anyone have any idea what has happened here? When I first connected the drive it worked fine, if a bit on the slow side. How could changing the USB port affect the BIOS from recognizing three of my internal hard drives? This is definitely not good. Any help anyone could offer would be greatly appreciated.

I then tried disabling USB legacy support at the suggestion of a WD tech:

I changed the USB setting in the BIOS to disable legacy support, and restarted the system. It booted into Windows, which of course was good. It did have the screen up showing that Windows had ended unexpectedly and asked if I wanted to start it normally (which I did). The Windows desktop showed for a minute or two, but I was unable to do anything on it as the system was unresponsive. Also, the drive light was on, but I have no way of knowing which drive was being accessed. Then, the screen went black with the mouse cursor showing in the middle of the screen. I could move it, but there was nothing to click. Then the system rebooted itself, and once again the same drives were no longer visible to the BIOS. I tried booting the system with the drive unplugged and got the same thing.

The boot messages are somewhat different now that I have USB legacy support disabled:

USB Legacy Support Disabled in the Setup !

Auto-Detecting SATA 3 Dev… IDE Hard Disk (this is a new message and I have no IDE drives installed on this system).

The system will hang on this message for a few minutes, and then quickly boot to the “no boot device found” warning. It has also given me a Windows message telling me that something has changed in Windows and I should put in the original Windows CD and run the “repair Windows” option. Of course, there’s little point in that as the system cannot see the boot drive anyway (and apparently Windows is still installed and working assuming the system can locate the boot drive).

Incidentally, I have another PC (the one I’m using to write you) and I put one of the old 1 terrabyte drives on it. It wouldn’t boot past the USB part of the startup until I disabled legacy support on it. Now it boots just fine, so at least that one works! Also, it doesn’t give me any messages or warnings about the USB legacy support being disabled.

Thanks for any suggestions any of you can provide!

PS – The system is a TPower I45 mother board with 6 gig of RAM with a BIOS date of 9-21-2010 (I just updated it) and  I’m running Windows 7 Professional 64 bit.

Hi there, since you have another computer why not trying to see if the drives are seen in the other and try to take the files out before restoring Windowa? o.o