My device does not store the last entered source


I can select a windows share as a source to watch videos, and so on.

the device is loosing the last entered source I have choosen after every restart.

I’ve read that the device needs (an undefind) time to save this setting.

I have waited, but it doesn’t work.

What to do now?

Thank you

Hi there, welcome to the community.

Have you tried resetting the unit? What kind of media player do you have? Is the media player on the latest version of the firmware?

Thank you,

Yes, tried to reset…

I have got an “WDTV Media Player (Generation 4)” and it is operation on latest firmware “1.02.17”.

The hardware model number is: WDBPUF0000NBK-00

This is weird, I have the same media player on the same version of the firmware and it remembers the last source I accessed, that be, media server, local storage or network share. You should  contact WD and see if their support has any information on this.

Add the Network Share to your Media Library and it will remember it

Page 202 in the User Manual