My clouds usb is not mounting usb drives, again: code 1122,

i am a bit miffed today i had this isue with three my cloud drives all within a 10 day period of the new update and getting the new win 10 i took them out and plugged them into a hub ad until today i tried forget about it and saved up and bought new usb drives. i am surprised that WD have not fully publicised a solution or fix to this issuse with the usb port on the my cloud drives i gave them enough info and after all this time because there are so many people have this problem since the last upgrade and the introduction to the free win 10. but nothing serious enough was done…
what if WD did not want to fix this but rather let you buy mirror drives to do what could be done with the usb etc when a drive i used for back up just “broke” this was used for back up the main help i got was 'it was too late by that time for any help "why dont you get a mirror drive for this situation, fact is this drive just stopped for no good reason it effectively would have been the second drive in the mirror drive if i had one, you see? i suppose it could be any drive that goes which does not give any confidence. more like i have become a sceptic now.
so the usb on two of my cloud drives has failed to keep usb drives mounted code 1122 etc and so i bought brand new passports weeks later [this week now] and both cloud drives wont mount either of them, annoying!. if i bought a mirror drive, which also has two usb ports on them, just what assurance is there that they would work either??? you would expect it to do its job, right? or else whats it there for!? it all seems to me that too many usb’s on my cloud drives do not simply plug and play as they should do and not enough has been done to fix or get around this before the drives are sold or replaced, what if this has always been an issue and they got thousands of them sitting on a shelf waiting to go out to someone hoping to use the usb cause he cant afford a mirror drive?
if there is a solution that does not involve running in crcles or through rings please let me know.
i still welcome a solution though.

1 Like

A suggestion you may want to reformat your post as its almost unreadable due to the lack of paragraphs and punctuation.

This is a user to user support forum. If you do a forum search, using the magnifying glass icon upper right, you’ll see there are numerous discussions on the single bay My Cloud having trouble mounting some USB external hard drive devices. There are various suggestions detailed in some of those threads that have helped some fix their mounting issues.

Not sure what Windows 10 has to do with the My Cloud not mounting a USB hard drive. If you are having a specific Windows 10 problem mounting a USB hard drive you attached to a Windows 10 PC then contact Microsoft. There is a recent problem with Windows 10 not properly accessing/mounting certain external USB hard drive. See the following link for that Microsoft Windows 10 issue:

Couple of suggestions if you are having trouble with the My Cloud not properly mounting a USB hard drive:

Eject the USB hard drive using the My Cloud Dashboard, then remove the USB hard drive and reboot the My Cloud. Let the My Cloud completly boot up to a blue LED then insert the USB hard drive into the My Cloud and wait several minutes, then check the Dashboard to see if the drive has been properly mounted.

If you have USB Content Availability enabled in the My Cloud Dashboard > Settings, disable it and try attaching the USB hard drive again.

One could take a look at the autoMount.db file using SSH to see what it is showing for attached USB devices. One could attempt to edit the autoMount.db to remove the USB hard drive entry that is failing to mount, reboot the My Cloud then reattach the USB drive and see if the My Cloud will properly mount the drive. Do a subforum search for autoMount.db as there are several discussions about that database and USB drive issues.

Try using a powered USB hub and attach the USB drive to the powered hub and attach the powered hub to the My Cloud USB port.

Even though this post is 6 years old, this still seems to be an issue with WD Drives. I just chimed in to say thank you because this solution actually solved the problem. I was just about to give up and send the HDD back (5TB Black Game Drive) but thanks to you writing this up in a way that any novice could understand, I don’t have to.
Sincerely, Diamond