My Cloud Won't Sleep

Continuing the discussion from My cloud won't sleep:

I get the same issue as Alistair_Gordon above. My 3TB My Cloud refuses to sleep all for a sudden. I can see some process active using SSH i.e. wdmcserver. So I presume its indexing. But I don’t upload much content. And this has been running for 2 weeks, I’ve tried a system factory reset and content database rebuild too in case there is disk corruption. No idea whats going on. I just want the drive to sleep when not in use.

There are some SSH commands that can disable various processes such as wdmcserver. What are the consequences of this? Can I no longer access my NAS remotely? And how would this impact thumbnail generation and indexing?

I don’t have access to my cloud right now. but in /etc/rc2.d there is a script called S20restsdk-serverd
If you stop this process. Your cloud should now sleep. This process is writing to disk every ten second. If you have disabled remote cloud access.


Thanks for your message. I have remote cloud access enabled. If I disable the restsdk-server service. Will I still be able to access my cloud box remotely when I need to?

Thanks again

I think so. I thought that was your problem. How do you know that it does not sleep. The easy was to check if it is sleeping is the blue light will fade on and off while it is sleeping.


The drive constantly spins and the blue light is solid.

CAN YOU SAY SOMETHING ABOUT WHAT THIS MEANS? Where does one SEE this “/etc/rc2.d” thing?? How does one STOP this thing?

With some MyCloud no sleep threads receiving in excess of 2500 views and no solution to be had, I think I am perfectly justified when I call this thing JUNK.