"My Cloud" visible in browser but not as mapped drive

Hi All,

Been trying to sort this one out for a few days now. I am able to connect to my device using the, which it brings up fine. It does not show however the SMB protocols as one of the WD articles mentioned, so I can’t change those. Basically, WD Link can’t see the device, neither can WD Discovery. I can’t map a drive to it using the IP address either.

I’m now stuck! I want to be able to upload content on it and use the back up software I have on my laptop, which runs against the mapped drive I previously assigned. But since the firmware update, the laptop can only see it via the web interface.


Many thanks,


Has this device ever worked for you, or is this a new install?

If this is a new install, try a 40 second reset. Use a paper clip, or other thin item to depress the tiny button inside the hole on the back while the device is powered off. While holding the button in, turn the device on, and continue holding for 40 seconds.

This should reset the device to factory defaults, which will include creating a [Public] share.

It’s been working for what must be a couple of years. If I factory reset, should that also restore it to the original firmware version? I tried that yesterday and it’s still on what looks to be the most recent firmware update.

Cheers, Aaron

No. Performing a reset only resets the settings for the current firmware installed on the My Cloud. The WD Knowledgebase article on resetting:


Hi guys! I’d like to know if your issue was resolved. I have the same problem with my MyCloud device. The only thing I did before this problem happened was to change our router.

What brand/model router did you change to? If an AT&T Uverse router or one of the routers listed in the following WD Support document there is a know issue with those routers and the My Cloud. The solution/workaround is to put a switch between the My Cloud and router.


I’ll try this out. Thanks! :slight_smile:

Hi Bennor. It worked! I can now access the dashboard. But I think have to map the drive again.