My Cloud - Totally Useless To Me

Because of the recent firmware update, I am unable to upload large files to My Cloud.  I am also unable to see it on the network, so I can’t map it, or select it as a destination for sending a file to it via FTP.  With these two major problems unfixed, the My Cloud puchase is seeming more like wasted money, than anything else.  I was hoping for better.  


Have you tried resetting and/or power cycling the drive after the firmware update?

**Update**  This morning, I did a reset power on - by using the reset button on the rear of the unit - and it got all the way up 800+MB uploaded before it died.  Then it reverts to 0MB, then 318Bytes.  It also tries to estimate upload time, but never does. 

As of 2:00 EDT, on 7/31/14 my My Cloud issues have all been resolved, courtesy of Jon, who did a wonderful job.  Good customer service is very hard to find, and it is very much appreciated.  It looked as if the unit was being held up by one of the users.  As soon as he performed a system only reset, it worked perfectly, and appeared on my LAN.

Now, I’m camping happily again.

Thanks go to Jon.